image: fix initramfs image name
authorGabor Juhos <juhosg@openwrt.org>
Fri, 19 Jul 2013 17:12:45 +0000 (17:12 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Fri, 19 Jul 2013 17:12:45 +0000 (17:12 +0000)
Preserve order of components in initramfs image filename
when doing copy from $(KDIR) to $(BIN_DIR).

Patchwork: http://patchwork.openwrt.org/patch/3811/
Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 37452

include/image.mk

index 7d63a1823268b85ccff34da10594ce12a5b6e1ce..80be17afd7215bbf425ba5cee9326bebc6e219f3 100644 (file)
@@ -69,7 +69,7 @@ endef
 
 ifneq ($(CONFIG_TARGET_ROOTFS_INITRAMFS),)
   define Image/BuildKernel/Initramfs
-       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-initramfs-vmlinux.elf
+       cp $(KDIR)/vmlinux-initramfs.elf $(BIN_DIR)/$(IMG_PREFIX)-vmlinux-initramfs.elf
        $(call Image/Build/Initramfs)
   endef
 else