uboot-at91: fix build after fpu activation
authorSandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
Thu, 4 Jan 2018 19:43:23 +0000 (12:43 -0700)
committerHauke Mehrtens <hauke@hauke-m.de>
Tue, 9 Jan 2018 21:58:49 +0000 (22:58 +0100)
neon and VFPv4 support is added to this target and uboot-at91 build
fails due to TARGET_CFLAGS -mfloat-abi set to hard. as a fix, setting
uboot-at91 CFLAGS -mfloat-abi=soft.

Fixes: 01cc6bd495f ("at91: sama5: activate fpu")
Signed-off-by: Sandeep Sheriker Mallikarjun <sandeepsheriker.mallikarjun@microchip.com>
package/boot/uboot-at91/Makefile

index 7c420f1262b02ad59695377cc5f7d3358f33aa41..268b254206efa4a6b02a1a96d10a7400e6de9bd6 100644 (file)
@@ -88,7 +88,7 @@ UBOOT_TARGETS := \
 define Build/Compile
        +$(MAKE) $(PKG_JOBS) -C $(PKG_BUILD_DIR) \
                CROSS_COMPILE=$(TARGET_CROSS) \
-               KCFLAGS="$(filter-out -fstack-protector, $(TARGET_CFLAGS))"
+               KCFLAGS="$(filter-out -fstack-protector -mfloat-abi=hard, $(TARGET_CFLAGS)) -mfloat-abi=soft" 
 endef
 
 $(eval $(call BuildPackage/U-Boot))