mtd: avoid adding the kernel dir to includes, use the toolchain headers
authorFelix Fietkau <nbd@openwrt.org>
Sun, 4 Nov 2012 17:01:30 +0000 (17:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sun, 4 Nov 2012 17:01:30 +0000 (17:01 +0000)
SVN-Revision: 34071

package/mtd/Makefile

index c6b94ffdf6548e1a93eb395efbbe8a996689ad52..f429128e02d41ab62b925f3f8cf978d3cb3ff0e7 100644 (file)
@@ -38,7 +38,7 @@ endef
 target=$(firstword $(subst -, ,$(BOARD)))
 
 MAKE_FLAGS += TARGET="$(target)"
-TARGET_CFLAGS := -I$(LINUX_DIR)/include $(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall
+TARGET_CFLAGS := $(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall
 
 ifdef CONFIG_MTD_REDBOOT_PARTS
   MAKE_FLAGS += FIS_SUPPORT=1