refresh 2.6.27 patches
authorFlorian Fainelli <florian@openwrt.org>
Fri, 31 Jul 2009 11:10:20 +0000 (11:10 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Fri, 31 Jul 2009 11:10:20 +0000 (11:10 +0000)
SVN-Revision: 17061

target/linux/brcm63xx/patches-2.6.27/001-add_broadcom_63xx_cpu_definitions.patch
target/linux/brcm63xx/patches-2.6.27/008-usb_ehci_support.patch
target/linux/generic-2.6/patches-2.6.27/004-extra_optimization.patch
target/linux/generic-2.6/patches-2.6.27/208-rtl8110sb_fix.patch

index 9d33edc2a19171499dc068ad7dce37649e2ad634..163f8bea5258706bea610cae83ff0f67f3c379a9 100644 (file)
@@ -22,7 +22,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
                cpu_wait = r4k_wait;
                break;
  
-@@ -802,11 +806,28 @@ static inline void cpu_probe_broadcom(st
+@@ -802,11 +805,28 @@ static inline void cpu_probe_broadcom(st
        decode_configs(c);
        switch (c->processor_id & 0xff00) {
        case PRID_IMP_BCM3302:
@@ -51,7 +51,7 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
        default:
                c->cputype = CPU_UNKNOWN;
                break;
-@@ -892,6 +913,10 @@ static __cpuinit const char *cpu_to_name
+@@ -892,6 +912,10 @@ static __cpuinit const char *cpu_to_name
        case CPU_SR71000:       name = "Sandcraft SR71000"; break;
        case CPU_BCM3302:       name = "Broadcom BCM3302"; break;
        case CPU_BCM4710:       name = "Broadcom BCM4710"; break;
index 4019683333c02fcce1a6d94f2b6a70f37ca5cfe2..b656a2cb923c4b96557948c1d78cdce06d9ee438 100644 (file)
@@ -45,9 +45,9 @@ Signed-off-by: Maxime Bizon <mbizon@freebox.fr>
  static inline unsigned int ehci_readl(const struct ehci_hcd *ehci,
                __u32 __iomem * regs)
  {
---- a/drivers/usb/host/Kconfig 2009-07-03 01:33:19.000000000 +0200
-+++ b/drivers/usb/host/Kconfig 2009-07-17 17:53:11.000000000 +0200
-@@ -44,7 +44,7 @@
+--- a/drivers/usb/host/Kconfig
++++ b/drivers/usb/host/Kconfig
+@@ -44,7 +44,7 @@ config USB_EHCI_HCD
  
  config USB_EHCI_ROOT_HUB_TT
        bool "Root Hub Transaction Translators"
index d6866899c302126c29c359ad749c1d5fea7c5ef7..9a15d5d378eefe96b027577fdb782104d891d312 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile
 +++ b/Makefile
-@@ -549,6 +549,9 @@ endif
+@@ -550,6 +550,9 @@ endif
  NOSTDINC_FLAGS += -nostdinc -isystem $(shell $(CC) -print-file-name=include)
  CHECKFLAGS     += $(NOSTDINC_FLAGS)
  
index e89f81754a68e4e5fcb6752e28edced805197d82..297db2ac7ea20c833f7f4f668815809ab9fed5e7 100644 (file)
                                  RxFIFOOver | TxErr | TxOK | RxOK | RxErr,
                .napi_event     = RxFIFOOver | TxErr | TxOK | RxOK | RxOverflow,
                .features       = RTL_FEATURE_MSI
-@@ -2878,10 +2878,12 @@ static irqreturn_t rtl8169_interrupt(int
-               goto out;
-       }
+@@ -2872,12 +2872,12 @@ static irqreturn_t rtl8169_interrupt(int
+                       rtl8169_tx_timeout(dev);
+                       break;
+               }
+-
 +#if 0
-       if (unlikely(status & SYSErr)) {
-               rtl8169_pcierr_interrupt(dev);
-               goto out;
-       }
+               if (unlikely(status & SYSErr)) {
+                       rtl8169_pcierr_interrupt(dev);
+                       break;
+               }
+-
 +#endif
+               if (status & LinkChg)
+                       rtl8169_check_link_status(dev, tp, ioaddr);
  
-       if (status & LinkChg)
-               rtl8169_check_link_status(dev, tp, ioaddr);