ramips: use lzma-loader for Wevo devices
authorSeo Suchan <abnoeh@mail.com>
Wed, 17 Feb 2021 15:06:55 +0000 (00:06 +0900)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Fri, 19 Feb 2021 13:09:50 +0000 (14:09 +0100)
As kernel size increased it start to fail to load squishfs image,
using lzma-loader fixed it.
wevo_11acnas is almost same device as w2914ns-v2 except ram size,
so I expect same thing would've happen in that device too.

Signed-off-by: Seo Suchan <abnoeh@mail.com>
Reviewed-by: Sungbo Eo <mans0n@gorani.run>
target/linux/ramips/image/mt7621.mk

index a4edf0a6df3778b42d0ddf4b173f489bc591676f..396b112b760ec08e96b987e8bbac17db712d82e6 100644 (file)
@@ -1254,6 +1254,7 @@ TARGET_DEVICES += wavlink_wl-wn531a6
 
 define Device/wevo_11acnas
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   UIMAGE_NAME := 11AC-NAS-Router(0.0.0)
   DEVICE_VENDOR := WeVO
@@ -1266,6 +1267,7 @@ TARGET_DEVICES += wevo_11acnas
 
 define Device/wevo_w2914ns-v2
   $(Device/dsa-migration)
+  $(Device/uimage-lzma-loader)
   IMAGE_SIZE := 16064k
   UIMAGE_NAME := W2914NS-V2(0.0.0)
   DEVICE_VENDOR := WeVO