ath79: add support for TP-Link CPE510-v2/v3
authorAndrew Cameron <apcameron@softhome.net>
Wed, 26 Jun 2019 21:40:54 +0000 (16:40 -0500)
committerPetr Štetiar <ynezz@true.cz>
Wed, 17 Jul 2019 22:06:55 +0000 (00:06 +0200)
TP-Link CPE510-v2/v3 is an outdoor wireless CPE for 5 GHz with
one Ethernet port based on Atheros AR9344

Specifications:
 - Based on the same underlying hardware as the TP-Link CPE510
 - Power, LAN, and 4 green LEDs
 - 1 10/100Mbps Shielded Ethernet Port (Passive PoE in)
 - Built-in 13dBi 2x2 dual-polarized directional MIMO antenna
 - Adjustable transmission power from 0 to 23dBm/200mw

Flashing instructions:
 Flash factory image through stock firmware WEB UI
 or through TFTP
 To get to TFTP recovery just hold reset button while powering on for
 around 4-5 seconds and release.
 Rename factory image to recovery.bin
 Stock TFTP server IP:192.168.0.100
 Stock device TFTP adress:192.168.0.254

Signed-off-by: Andrew Cameron <apcameron@softhome.net>
[whitespace fixes]
Signed-off-by: Petr Štetiar <ynezz@true.cz>
target/linux/ath79/base-files/etc/board.d/01_leds
target/linux/ath79/base-files/etc/board.d/02_network
target/linux/ath79/dts/ar9344_tplink_cpe510-v2.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9344_tplink_cpe510-v3.dts [new file with mode: 0644]
target/linux/ath79/dts/ar9344_tplink_cpe510.dtsi [new file with mode: 0644]
target/linux/ath79/image/generic-tp-link.mk
tools/firmware-utils/src/tplink-safeloader.c

index 238dda18f6bf53522395a8d06d0b6adc293d4b58..0cb03db4bee93a4ba66e5dd566e3ea2a418050b1 100755 (executable)
@@ -158,6 +158,15 @@ tplink,cpe210-v3)
        ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "60" "100"
        ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:link4" "wlan0" "80" "100"
        ;;
+tplink,cpe510-v2|\
+tplink,cpe510-v3)
+       ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
+       ucidef_set_rssimon "wlan0" "200000" "1"
+       ucidef_set_led_rssi "rssilow" "RSSILOW" "tp-link:green:link1" "wlan0" "1" "100" "0" "13"
+       ucidef_set_led_rssi "rssimediumlow" "RSSIMEDIUMLOW" "tp-link:green:link2" "wlan0" "26" "100" "-25" "13"
+       ucidef_set_led_rssi "rssimediumhigh" "RSSIMEDIUMHIGH" "tp-link:green:link3" "wlan0" "51" "100" "-50" "13"
+       ucidef_set_led_rssi "rssihigh" "RSSIHIGH" "tp-link:green:link4" "wlan0" "76" "100" "-75" "13"
+       ;;
 tplink,cpe610-v1)
        ucidef_set_led_netdev "lan" "LAN" "tp-link:green:lan" "eth0"
        ;;
index 2413b1f4bc53458db777193cd1b03bfec8df874d..1d4cec025adbe7cf468e08376e8b3a9ca43368cd 100755 (executable)
@@ -28,6 +28,8 @@ ath79_setup_interfaces()
        pqi,air-pen|\
        tplink,cpe210-v2|\
        tplink,cpe210-v3|\
+       tplink,cpe510-v2|\
+       tplink,cpe510-v3|\
        tplink,cpe610-v1|\
        tplink,re350k-v1|\
        tplink,re355-v1|\
diff --git a/target/linux/ath79/dts/ar9344_tplink_cpe510-v2.dts b/target/linux/ath79/dts/ar9344_tplink_cpe510-v2.dts
new file mode 100644 (file)
index 0000000..758d0c0
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9344_tplink_cpe510.dtsi"
+
+/ {
+       compatible = "tplink,cpe510-v2", "qca,ar9344";
+       model = "TP-Link CPE510 v2";
+};
diff --git a/target/linux/ath79/dts/ar9344_tplink_cpe510-v3.dts b/target/linux/ath79/dts/ar9344_tplink_cpe510-v3.dts
new file mode 100644 (file)
index 0000000..0909fcf
--- /dev/null
@@ -0,0 +1,9 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include "ar9344_tplink_cpe510.dtsi"
+
+/ {
+       compatible = "tplink,cpe510-v3", "qca,ar9344";
+       model = "TP-Link CPE510 v3";
+};
diff --git a/target/linux/ath79/dts/ar9344_tplink_cpe510.dtsi b/target/linux/ath79/dts/ar9344_tplink_cpe510.dtsi
new file mode 100644 (file)
index 0000000..f19ef01
--- /dev/null
@@ -0,0 +1,152 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+/dts-v1/;
+
+#include <dt-bindings/gpio/gpio.h>
+#include <dt-bindings/input/input.h>
+
+#include "ar9344.dtsi"
+
+/ {
+       aliases {
+               led-boot = &system;
+               led-failsafe = &system;
+               led-running = &system;
+               led-upgrade = &system;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "tp-link:green:lan";
+                       gpios = <&gpio 11 GPIO_ACTIVE_LOW>;
+               };
+
+               link1 {
+                       label = "tp-link:green:link1";
+                       gpios = <&gpio 13 GPIO_ACTIVE_LOW>;
+               };
+
+               link2 {
+                       label = "tp-link:green:link2";
+                       gpios = <&gpio 14 GPIO_ACTIVE_LOW>;
+               };
+
+               link3 {
+                       label = "tp-link:green:link3";
+                       gpios = <&gpio 15 GPIO_ACTIVE_LOW>;
+               };
+
+               system: link4 {
+                       label = "tp-link:green:link4";
+                       gpios = <&gpio 16 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       keys {
+               compatible = "gpio-keys";
+
+               reset {
+                       linux,code = <KEY_RESTART>;
+                       gpios = <&gpio 4 GPIO_ACTIVE_LOW>;
+                       debounce-interval = <60>;
+               };
+       };
+
+};
+
+&ref {
+       clock-frequency = <40000000>;
+};
+
+&uart {
+       status = "okay";
+};
+
+&spi {
+       num-cs = <1>;
+
+       status = "okay";
+
+       flash@0 {
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <25000000>;
+
+               partitions {
+                       compatible = "fixed-partitions";
+                       #address-cells = <1>;
+                       #size-cells = <1>;
+
+                       uboot: partition@0 {
+                               label = "u-boot";
+                               reg = <0x000000 0x020000>;
+                               read-only;
+                       };
+
+                       partition@20000 {
+                               label = "partition-table";
+                               reg = <0x020000 0x010000>;
+                               read-only;
+                       };
+
+                       info: partition@30000 {
+                               label = "info";
+                               reg = <0x030000 0x010000>;
+                               read-only;
+                       };
+
+                       partition@40000 {
+                               label = "firmware";
+                               reg = <0x040000 0x780000>;
+
+                               compatible = "fixed-partitions";
+                               #address-cells = <1>;
+                               #size-cells = <1>;
+
+                               partition@0 {
+                                       label = "kernel";
+                                       reg = <0x000000 0x200000>;
+                               };
+
+                               partition@200000 {
+                                       label = "rootfs";
+                                       reg = <0x200000 0x580000>;
+                               };
+                       };
+
+                       partition@7c0000 {
+                               label = "config";
+                               reg = <0x7c0000 0x030000>;
+                               read-only;
+                       };
+
+                       art: partition@7f0000 {
+                               label = "art";
+                               reg = <0x7f0000 0x010000>;
+                               read-only;
+                       };
+               };
+       };
+};
+
+&wmac {
+       status = "okay";
+
+       mtd-cal-data = <&art 0x1000>;
+       mtd-mac-address = <&info 0x08>;
+};
+
+&eth0 {
+       status = "okay";
+
+       mtd-mac-address = <&info 0x08>;
+
+       phy-mode = "mii";
+       phy-handle = <&swphy4>;
+};
+
+&eth1 {
+       status = "okay";
+       compatible = "syscon", "simple-mfd";
+};
index f1424d02ee717e4da255c51687af44cbe75aaa5a..312ce78f226d3da0c2056e76269247eea8feafc3 100644 (file)
@@ -159,6 +159,40 @@ define Device/tplink_cpe210-v3
 endef
 TARGET_DEVICES += tplink_cpe210-v3
 
+define Device/tplink_cpe510-v2
+  $(Device/tplink-safeloader)
+  ATH_SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := CPE510
+  DEVICE_VARIANT := v2
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE510V2
+  LOADER_TYPE := elf
+  LOADER_FLASH_OFFS := 0x43000 
+  COMPILE := loader-$(1).elf 
+  COMPILE/loader-$(1).elf := loader-okli-compile 
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
+  SUPPORTED_DEVICES += cpe510-v2
+endef
+TARGET_DEVICES += tplink_cpe510-v2
+
+define Device/tplink_cpe510-v3
+  $(Device/tplink-safeloader)
+  ATH_SOC := ar9344
+  IMAGE_SIZE := 7680k
+  DEVICE_MODEL := CPE510
+  DEVICE_VARIANT := v3
+  DEVICE_PACKAGES := rssileds
+  TPLINK_BOARD_ID := CPE510V3
+  LOADER_TYPE := elf
+  LOADER_FLASH_OFFS := 0x43000 
+  COMPILE := loader-$(1).elf 
+  COMPILE/loader-$(1).elf := loader-okli-compile 
+  KERNEL := kernel-bin | append-dtb | lzma | uImage lzma -M 0x4f4b4c49 | loader-okli $(1) 12288
+  SUPPORTED_DEVICES += cpe510-v3
+endef
+TARGET_DEVICES += tplink_cpe510-v3
+
 define Device/tplink_cpe610-v1
   $(Device/tplink-safeloader)
   ATH_SOC := ar9344
index 773e7ed26cda8aa3abf1c691e0e7ce8160f73616..cfd36459509e0bffe6886a24924bc5e3ef24eb5e 100644 (file)
@@ -278,6 +278,91 @@ static struct device_info boards[] = {
                .first_sysupgrade_partition = "os-image",
                .last_sysupgrade_partition = "support-list",
        },
+
+       /** Firmware layout for the CPE510 V2 */
+       {
+               .id     = "CPE510V2",
+               .vendor = "CPE510(TP-LINK|UN|N300-5):2.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|00000000):2.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|45550000):2.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|55530000):2.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|00000000):2.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|45550000):2.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|55530000):2.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|00000000):2.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|45550000):2.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|55530000):2.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5):2.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5):2.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5):2.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"signature", 0x32000, 0x00400},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x00400},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
+       /** Firmware layout for the CPE510 V3 */
+       {
+               .id     = "CPE510V3",
+               .vendor = "CPE510(TP-LINK|UN|N300-5):3.0\r\n",
+               .support_list =
+                       "SupportList:\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|00000000):3.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|45550000):3.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5|55530000):3.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|00000000):3.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|45550000):3.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5|55530000):3.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|00000000):3.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|45550000):3.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5|55530000):3.0\r\n"
+                       "CPE510(TP-LINK|UN|N300-5):3.0\r\n"
+                       "CPE510(TP-LINK|EU|N300-5):3.0\r\n"
+                       "CPE510(TP-LINK|US|N300-5):3.0\r\n",
+               .support_trail = '\xff',
+               .soft_ver = NULL,
+
+               .partitions = {
+                       {"fs-uboot", 0x00000, 0x20000},
+                       {"partition-table", 0x20000, 0x02000},
+                       {"default-mac", 0x30000, 0x00020},
+                       {"product-info", 0x31100, 0x00100},
+                       {"signature", 0x32000, 0x00400},
+                       {"os-image", 0x40000, 0x200000},
+                       {"file-system", 0x240000, 0x570000},
+                       {"soft-version", 0x7b0000, 0x00100},
+                       {"support-list", 0x7b1000, 0x00400},
+                       {"user-config", 0x7c0000, 0x10000},
+                       {"default-config", 0x7d0000, 0x10000},
+                       {"log", 0x7e0000, 0x10000},
+                       {"radio", 0x7f0000, 0x10000},
+                       {NULL, 0, 0}
+               },
+
+               .first_sysupgrade_partition = "os-image",
+               .last_sysupgrade_partition = "support-list",
+       },
+
        /** Firmware layout for the CPE610V1 */
        {
                .id     = "CPE610V1",