imx6: add canbus support for Ventana boards
authorLuka Perkov <luka@openwrt.org>
Wed, 11 Dec 2013 10:56:11 +0000 (10:56 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 11 Dec 2013 10:56:11 +0000 (10:56 +0000)
GW5400, GW5300, and GW5200 have CAN bus option.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 39034

target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6dl-gw52xx.dts
target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6dl-gw53xx.dts
target/linux/imx6/files-3.10/arch/arm/boot/dts/imx6q-gw54xx.dts
target/linux/imx6/profiles/120-gateworks.mk

index 400c06485baa4b96c6c831a25963b5d21cf09942..eef42ed38ed82127724a152eb63d1bbeaa10dc20 100644 (file)
@@ -18,6 +18,7 @@
 
        /* these are used by bootloader for disabling nodes */
        aliases {
+               can0 = &can1;
                ethernet0 = &fec;
                i2c0 = &i2c1;
                i2c1 = &i2c2;
        status = "okay";
 };
 
+&can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
+       status = "okay";
+};
+
 &fec {
        pinctrl-names = "default";
        pinctrl-0 = <&pinctrl_enet_1>;
index 87f0be2e0aa6a60c2d25a3652b8da344a14cea46..99d3d4c459503f1a863ec231d391776cc9ece281 100644 (file)
 };
 
 &can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
        status = "okay";
 };
 
index f9cf29a990369742c8f7c4c4df2367456ce65d4c..828fc811830a43b362676bcaca1a19647add91b7 100644 (file)
 };
 
 &can1 {
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_flexcan1_1>;
        status = "okay";
 };
 
index 830b3b2e1f1c9f3d2a5a077731b0b0d09c684797..9891527a80f5e004bda8d21238fe04360aefd34a 100644 (file)
@@ -10,6 +10,7 @@ define Profile/VENTANA
   PACKAGES:= \
        kmod-thermal-imx kmod-sky2 kmod-usb-chipidea kmod-usb-mxs-phy \
        kmod-sound-soc-imx kmod-sound-soc-imx-sgtl5000 \
+       kmod-can kmod-can-flexcan \
        kobs-ng
 endef