lantiq: make AVM FRITZ!Box naming consistent
authorDavid Bauer <mail@david-bauer.net>
Tue, 22 Jan 2019 21:36:17 +0000 (22:36 +0100)
committerMathias Kresin <dev@kresin.me>
Sat, 26 Jan 2019 09:41:26 +0000 (10:41 +0100)
This commit changes the model string and device title of all AVM boards
to fit the naming of the manufacturer.

Drop all provider-specific titles as they are re-used for every device
generation by 1&1. The original AVM model name is printed on the bottom
of every devices.

Exception applies for boards which are only supported by a specific
sub-revision.

Signed-off-by: David Bauer <mail@david-bauer.net>
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370-REV2-HYNIX.dts
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370-REV2-MICRON.dts
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ3370-REV2.dtsi
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7312.dts
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7320.dts
target/linux/lantiq/files-4.14/arch/mips/boot/dts/FRITZ7360SL.dts
target/linux/lantiq/image/Makefile

index 3cb7d7d723c2609b00c2ed424f09b6e95953e0bd..ebd6f6e4c8e60ab201ca7037bd2844c8420b10a5 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "avm,fritz3370-rev2-hynix", "avm,fritz3370-rev2", "lantiq,xway", "lantiq,vr9";
-       model = "AVM Fritz!Box WLAN 3370 Rev. 2 (Hynix NAND)";
+       model = "AVM FRITZ!Box 3370 Rev. 2 (Hynix NAND)";
 };
 
 &localbus {
index 1a1be6fd3793fada6e4729c5b50435620bceef5b..dcc97d2808283dbbdca188dfa5532d2c6fa5ead4 100644 (file)
@@ -4,7 +4,7 @@
 
 / {
        compatible = "avm,fritz3370-rev2-micron", "avm,fritz3370-rev2", "lantiq,xway", "lantiq,vr9";
-       model = "AVM Fritz!Box WLAN 3370 Rev. 2 (Micron NAND)";
+       model = "AVM FRITZ!Box 3370 Rev. 2 (Micron NAND)";
 };
 
 &localbus {
index a7e0c71915839fdc15dbb3af9be48c9359c42fc6..9a0359d1ccdbbe5e0374e41ed1ba9fd1150543de 100644 (file)
@@ -5,7 +5,7 @@
 
 / {
        compatible = "avm,fritz3370-rev2", "lantiq,xway", "lantiq,vr9";
-       model = "AVM Fritz!Box WLAN 3370 Rev. 2";
+       model = "AVM FRITZ!Box 3370 Rev. 2";
 
        chosen {
                bootargs = "console=ttyLTQ0,115200";
index c14695413e87fb959079a8097cfbd6b5487dc20d..796b941ede689fabdf935fdce21bcb914e8b5f1b 100644 (file)
@@ -6,7 +6,7 @@
 
 / {
        compatible = "avm,fritz7312", "lantiq,xway", "lantiq,ar9";
-       model = "FritzBox 7312 (1&1 WLAN-MODEM)";
+       model = "AVM FRITZ!Box 7312";
 
        chosen {
                bootargs = "console=ttyLTQ0,115200";
index 45a59c012dea0669101781ea244a41b8304caaa4..cd274277d1a7d70a18551366430d99f2f82f24ac 100644 (file)
@@ -6,7 +6,7 @@
 
 / {
        compatible = "avm,fritz7320", "lantiq,xway", "lantiq,ar9";
-       model = "1&1 HomeServer";
+       model = "AVM FRITZ!Box 7320";
 
        chosen {
                bootargs = "console=ttyLTQ0,115200";
index 91520c8137f60cac2de2c467acdae4be3790b2aa..53623ab56c35cfea086dbee11a01f162d736a8d0 100644 (file)
@@ -7,7 +7,7 @@
 
 / {
        compatible = "avm,fritz7360sl", "lantiq,xway", "lantiq,vr9";
-       model = "1&1 HomeServer";
+       model = "AVM FRITZ!Box 7360 SL";
 
        chosen {
                bootargs = "console=ttyLTQ0,115200";
index e9d9e4202783b653deb9fb49598347ce01272549..b59acf4ddcb6abc06b00909932b6a262aaf9c7ef 100644 (file)
@@ -489,7 +489,7 @@ define Device/avm_fritz7312
   $(Device/AVM)
   DEVICE_DTS := FRITZ7312
   IMAGE_SIZE := 15744k
-  DEVICE_TITLE := 1&1 WLAN-MODEM - FRITZ7312
+  DEVICE_TITLE := AVM FRITZ!Box 7312
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-mini \
        kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
        kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
@@ -502,7 +502,7 @@ define Device/avm_fritz7320
   $(Device/AVM)
   DEVICE_DTS := FRITZ7320
   IMAGE_SIZE := 15744k
-  DEVICE_TITLE := 1&1 HomeServer - FRITZ7320
+  DEVICE_TITLE := AVM FRITZ!Box 7320
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic \
        kmod-ltq-adsl-ar9-mei kmod-ltq-adsl-ar9 \
        kmod-ltq-adsl-ar9-fw-b kmod-ltq-atm-ar9 \
@@ -631,7 +631,7 @@ define Device/avm_fritz3370
   $(Device/AVM)
   $(Device/NAND)
   DEVICE_DTS := FRITZ3370
-  DEVICE_TITLE := AVM Fritz!Box WLan 3370 Rev. 2
+  DEVICE_TITLE := AVM FRITZ!Box 3370 Rev. 2
   KERNEL_SIZE := 4096k
   UBINIZE_OPTS := -E 5
   IMAGES += eva-kernel.bin eva-filesystem.bin
@@ -643,14 +643,14 @@ endef
 define Device/avm_fritz3370-rev2-hynix
   $(Device/avm_fritz3370)
   DEVICE_DTS := FRITZ3370-REV2-HYNIX
-  DEVICE_TITLE := AVM Fritz!Box WLan 3370 Rev. 2 (Hynix NAND)
+  DEVICE_TITLE := AVM FRITZ!Box 3370 Rev. 2 (Hynix NAND)
 endef
 TARGET_DEVICES += avm_fritz3370-rev2-hynix
 
 define Device/avm_fritz3370-rev2-micron
   $(Device/avm_fritz3370)
   DEVICE_DTS := FRITZ3370-REV2-MICRON
-  DEVICE_TITLE := AVM Fritz!Box WLan 3370 Rev. 2 (Micron NAND)
+  DEVICE_TITLE := AVM FRITZ!Box 3370 Rev. 2 (Micron NAND)
 endef
 TARGET_DEVICES += avm_fritz3370-rev2-micron
 
@@ -658,7 +658,7 @@ define Device/avm_fritz7360sl
   $(Device/AVM)
   IMAGE_SIZE := 15744k
   DEVICE_DTS := FRITZ7360SL
-  DEVICE_TITLE := 1&1 HomeServer - FRITZ7360SL
+  DEVICE_TITLE := AVM FRITZ!Box 7360 SL
   DEVICE_PACKAGES := kmod-ath9k kmod-owl-loader wpad-basic kmod-usb-dwc2
   SUPPORTED_DEVICES += FRITZ7360SL
 endef