include/autoconf.mk: decouple host fixups from target fixups
authorFelix Fietkau <nbd@openwrt.org>
Wed, 20 Jan 2016 19:12:28 +0000 (19:12 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Wed, 20 Jan 2016 19:12:28 +0000 (19:12 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 48403

include/autotools.mk

index 3316998dc987f3318a37f5c9fce5515a2b0edee1..3e028fa72de35d7dadd78fd7316e890cb298be7a 100644 (file)
@@ -143,27 +143,21 @@ define patch_libtool_host
     $(HOST_BUILD_DIR)))
 endef
 
-ifneq ($(filter patch-libtool,$(PKG_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(PKG_FIXUP)),)
   Hooks/HostConfigure/Pre += patch_libtool_host
 endif
 
-ifneq ($(filter patch-libtool,$(HOST_FIXUP)),)
+ifneq ($(filter patch-libtool-host,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += $(strip $(call patch_libtool,$(HOST_BUILD_DIR)))
 endif
 
-ifneq ($(filter libtool,$(HOST_FIXUP)),)
- ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
-  Hooks/HostConfigure/Pre += autoreconf_host
- endif
-endif
-
-ifneq ($(filter libtool-ucxx,$(HOST_FIXUP)),)
+ifneq ($(filter libtool-host,$(HOST_FIXUP)),)
  ifeq ($(filter no-autoreconf,$(HOST_FIXUP)),)
   Hooks/HostConfigure/Pre += autoreconf_host
  endif
 endif
 
-ifneq ($(filter autoreconf,$(HOST_FIXUP)),)
+ifneq ($(filter autoreconf-host,$(HOST_FIXUP)),)
   ifeq ($(filter autoreconf,$(Hooks/HostConfigure/Pre)),)
     Hooks/HostConfigure/Pre += autoreconf_host
   endif