oxnas: kd20: revert accedintally commited change
authorDaniel Golle <daniel@makrotopia.org>
Sat, 29 Aug 2020 00:13:56 +0000 (01:13 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Sat, 29 Aug 2020 00:16:24 +0000 (01:16 +0100)
Changing the factory image of KD20 was used during testing and wasn't
intended to be included in the commit fixing a SATA bug on oxnas.
Revert that part of the commit.

Fixes: 5793112f75 ("oxnas: reduce size of ATA DMA descriptor space")
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/oxnas/image/ox820.mk

index a52e09786b8a66e1566ca4d71a87555e7195292f..f00cfe86080e516e873d233ab9aa466f6b96dfff 100644 (file)
@@ -68,6 +68,10 @@ define Device/shuttle_kd20
   DEVICE_VENDOR := Shuttle
   DEVICE_MODEL := KD20
   SUPPORTED_DEVICES += kd20
+  KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
+  KERNEL_INITRAMFS_SUFFIX := .tar.gz
+  KERNEL_INITRAMFS = kernel-bin | append-dtb | uImage none | omninas-factory | \
+       encrypt-3des sohmuntitnlaes
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb3 kmod-usb-ledtrig-usbport \
        kmod-i2c-gpio kmod-rtc-pcf8563 kmod-gpio-beeper kmod-hwmon-drivetemp \
        kmod-hwmon-gpiofan kmod-ata-oxnas-sata kmod-md-mod kmod-md-raid0 \