kernel: update 3.14 to 3.14.32
authorLuka Perkov <luka@openwrt.org>
Sat, 7 Feb 2015 17:48:33 +0000 (17:48 +0000)
committerLuka Perkov <luka@openwrt.org>
Sat, 7 Feb 2015 17:48:33 +0000 (17:48 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 44302

include/kernel-version.mk
target/linux/generic/patches-3.14/432-mtd-bcm47xxpart-detect-T_Meter-partition.patch
target/linux/generic/patches-3.14/902-debloat_proc.patch

index 3cfcc8cd0aadfd38a9e7df19262c8e7b0826ee9a..cd282888b1fe93845a397a0e3f592785e604dd99 100644 (file)
@@ -5,14 +5,14 @@ LINUX_RELEASE?=1
 LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
 LINUX_VERSION-3.8  = .13
 LINUX_VERSION-3.10 = .58
 LINUX_VERSION-3.13 = .7
-LINUX_VERSION-3.14 = .30
+LINUX_VERSION-3.14 = .32
 LINUX_VERSION-3.18 = .5
 LINUX_VERSION-3.19 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
 LINUX_VERSION-3.18 = .5
 LINUX_VERSION-3.19 = -rc5
 
 LINUX_KERNEL_MD5SUM-3.8.13  = 2af19d06cd47ec459519159cdd10542d
 LINUX_KERNEL_MD5SUM-3.10.58 = 3ff3478b6351143cef22d4b81cf48b01
 LINUX_KERNEL_MD5SUM-3.13.7  = 370adced5e5c1cb1d0d621c2dae2723f
-LINUX_KERNEL_MD5SUM-3.14.30 = 5926982f20bbef0988fca03b92fe43a5
+LINUX_KERNEL_MD5SUM-3.14.32 = 3178fb8f6f1eafcffdd730fec68754f8
 LINUX_KERNEL_MD5SUM-3.18.5  = b655fcbc4597aa4b0cbabcfc72983259
 
 ifdef KERNEL_PATCHVER
 LINUX_KERNEL_MD5SUM-3.18.5  = b655fcbc4597aa4b0cbabcfc72983259
 
 ifdef KERNEL_PATCHVER
index 3f702259805b7eaa4ceb3d570c934eb15c55e37e..1edc99525dd10c6790d8d99a00664236a6d8cd89 100644 (file)
@@ -14,8 +14,6 @@ Signed-off-by: Rafał Miłecki <zajec5@gmail.com>
  drivers/mtd/bcm47xxpart.c | 10 ++++++++++
  1 file changed, 10 insertions(+)
 
  drivers/mtd/bcm47xxpart.c | 10 ++++++++++
  1 file changed, 10 insertions(+)
 
-diff --git a/drivers/mtd/bcm47xxpart.c b/drivers/mtd/bcm47xxpart.c
-index f14ec0f..40dd0db 100644
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
 @@ -39,6 +39,7 @@
 --- a/drivers/mtd/bcm47xxpart.c
 +++ b/drivers/mtd/bcm47xxpart.c
 @@ -39,6 +39,7 @@
@@ -26,10 +24,11 @@ index f14ec0f..40dd0db 100644
  #define ML_MAGIC1                     0x39685a42
  #define ML_MAGIC2                     0x26594131
  #define TRX_MAGIC                     0x30524448
  #define ML_MAGIC1                     0x39685a42
  #define ML_MAGIC2                     0x26594131
  #define TRX_MAGIC                     0x30524448
-@@ -177,6 +178,15 @@ static int bcm47xxpart_parse(struct mtd_info *master,
+@@ -176,6 +177,15 @@ static int bcm47xxpart_parse(struct mtd_
+                                            MTD_WRITEABLE);
                        continue;
                }
                        continue;
                }
++
 +              /* T_Meter */
 +              if ((le32_to_cpu(buf[0x000 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
 +                  (le32_to_cpu(buf[0x030 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
 +              /* T_Meter */
 +              if ((le32_to_cpu(buf[0x000 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
 +                  (le32_to_cpu(buf[0x030 / 4]) & 0xFFFF0000) == T_METER_MAGIC &&
@@ -38,10 +37,6 @@ index f14ec0f..40dd0db 100644
 +                                           MTD_WRITEABLE);
 +                      continue;
 +              }
 +                                           MTD_WRITEABLE);
 +                      continue;
 +              }
-+
                /* TRX */
                if (buf[0x000 / 4] == TRX_MAGIC) {
                /* TRX */
                if (buf[0x000 / 4] == TRX_MAGIC) {
-                       if (BCM47XXPART_MAX_PARTS - curr_part < 4) {
--- 
-1.8.4.5
-
index 9024d6401e98abfb9c02f84fb20cf6c6ceb28232..55e21a43ba38c367ddc40d32cc0ed1037f793580 100644 (file)
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1302,10 +1302,12 @@ static int __init setup_vmstat(void)
+@@ -1303,10 +1303,12 @@ static int __init setup_vmstat(void)
        put_online_cpus();
  #endif
  #ifdef CONFIG_PROC_FS
        put_online_cpus();
  #endif
  #ifdef CONFIG_PROC_FS