add a profile using proprietary wl instead of b43
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Jun 2010 13:32:40 +0000 (13:32 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 20 Jun 2010 13:32:40 +0000 (13:32 +0000)
SVN-Revision: 21851

target/linux/brcm47xx/Makefile
target/linux/brcm47xx/profiles/100-Broadcom-b43.mk
target/linux/brcm47xx/profiles/101-Broadcom-wl.mk [new file with mode: 0644]

index 56c87e482064a3c65521fc6a06194910025353a4..eae5ca3e37337242382707446a0907da7af7fb67 100644 (file)
@@ -14,7 +14,7 @@ FEATURES:=squashfs usb pcmcia
 LINUX_VERSION:=2.6.32.14
 
 include $(INCLUDE_DIR)/target.mk
-DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
+DEFAULT_PACKAGES += kmod-switch kmod-diag nvram
 
 define Target/Description
        Build firmware images for Broadcom based routers
index d5c425d9e11bdbc5f690ae9800f130a78e9cc5ea..12421800924b3ac378c5a5e2121741cf2702f1d7 100644 (file)
@@ -1,17 +1,19 @@
 #
-# Copyright (C) 2007-2008 OpenWrt.org
+# Copyright (C) 2007-2010 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
 #
 
 define Profile/Broadcom-b43
-  NAME:=Broadcom BCM43xx WiFi (default)
-  PACKAGES:=kmod-b43 kmod-b43legacy
+  NAME:=Broadcom BCM43xx WiFi - "b43" driver (default)
+  PACKAGES:=wpad-mini kmod-b43 kmod-b43legacy
 endef
 
 define Profile/Broadcom-b43/Description
        Package set compatible with hardware using Broadcom BCM43xx cards
+       using the MAC80211 b43 and b43legacy drivers.
 endef
+
 $(eval $(call Profile,Broadcom-b43))
 
diff --git a/target/linux/brcm47xx/profiles/101-Broadcom-wl.mk b/target/linux/brcm47xx/profiles/101-Broadcom-wl.mk
new file mode 100644 (file)
index 0000000..4cfb089
--- /dev/null
@@ -0,0 +1,19 @@
+#
+# Copyright (C) 2010 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Broadcom-wl
+  NAME:=Broadcom BCM43xx WiFi - "wl" driver (proprietary)
+  PACKAGES:=kmod-brcm-wl wlc nas
+endef
+
+define Profile/Broadcom-wl/Description
+       Package set compatible with hardware using Broadcom BCM43xx cards
+       using the proprietary broadcom wireless "wl" driver.
+endef
+
+$(eval $(call Profile,Broadcom-wl))
+