rename hostap package to hostap-driver
authorNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 08:21:42 +0000 (08:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Mon, 3 Sep 2007 08:21:42 +0000 (08:21 +0000)
SVN-Revision: 8588

package/hostap-driver/Makefile [new file with mode: 0644]
package/hostap/Makefile [deleted file]

diff --git a/package/hostap-driver/Makefile b/package/hostap-driver/Makefile
new file mode 100644 (file)
index 0000000..0b526b6
--- /dev/null
@@ -0,0 +1,133 @@
+# 
+# Copyright (C) 2006 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+# $Id$
+
+include $(TOPDIR)/rules.mk
+include $(INCLUDE_DIR)/kernel.mk
+
+PKG_NAME:=hostap-driver
+PKG_VERSION:=0.4.9
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
+PKG_MD5SUM:=c7534dc040ab90218257a78488ecd378
+
+include $(INCLUDE_DIR)/package.mk
+ifeq ($(DUMP),)
+  -include $(LINUX_DIR)/.config
+endif
+
+define KernelPackage/hostap/Default/2.4
+  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+define KernelPackage/hostap/Default/2.6
+  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
+endef
+define KernelPackage/hostap/Default
+  SUBMENU:=Wireless Drivers
+  DESCRIPTION:=\
+       Host AP is a driver for 802.11b wireless cards based on Intersil \\\
+       Prism2/2.5/3 chipset. It supports so called Host AP mode that allows the \\\
+       card to act as an IEEE 802.11 access point.
+  URL:=http://hostap.epitest.fi/
+  $(call KernelPackage/hostap/Default/$(KERNEL))
+endef
+
+
+define KernelPackage/hostap
+  $(call KernelPackage/hostap/Default)
+  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +kmod-crypto
+  TITLE:=Host AP support for Prism2/2.5/3
+  KCONFIG:=CONFIG_HOSTAP
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the base Host AP driver code that is shared by \\\
+       different hardware models. You will also need to enable support for \\\
+       PLX/PCI/CS version of the driver to actually use the driver.
+endef
+define KernelPackage/hostap/2.4
+  DEPENDS:=+kmod-crypto
+  FILES:= \
+       $(PKG_BUILD_DIR)/driver/modules/hostap.$(LINUX_KMOD_SUFFIX) \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.$(LINUX_KMOD_SUFFIX) \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_tkip.$(LINUX_KMOD_SUFFIX) \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,hostap hostap_crypt_wep hostap_crypt_tkip hostap_crypt_ccmp)
+endef
+define KernelPackage/hostap/2.6
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
+  AUTOLOAD:=$(call AutoLoad,60,hostap)
+endef
+
+
+define KernelPackage/hostap-pci
+  $(call KernelPackage/hostap/Default)
+  DEPENDS:=kmod-hostap
+  TITLE:=Host AP driver for PCI adaptors
+  KCONFIG:=CONFIG_HOSTAP_PCI
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the Host AP driver for Prism2.5 PCI adaptors.
+  AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
+endef
+define KernelPackage/hostap-pci/2.4
+  FILES:= \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_pci.$(LINUX_KMOD_SUFFIX)
+endef
+define KernelPackage/hostap-pci/2.6
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
+endef
+
+
+define KernelPackage/hostap-plx
+  $(call KernelPackage/hostap/Default)
+  DEPENDS:=kmod-hostap
+  KCONFIG:=CONFIG_HOSTAP_PLX
+  TITLE:=Host AP driver for PLX9052 based PCI adaptors
+  DESCRIPTION+=\\\
+       \\\
+       This package contains the Host AP driver for Prism2/2.5/3 in PLX9052 \\\
+       based PCI adaptors.
+  AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
+endef
+define KernelPackage/hostap-plx/2.4
+  FILES:= \
+       $(PKG_BUILD_DIR)/driver/modules/hostap_plx.$(LINUX_KMOD_SUFFIX)
+endef
+define KernelPackage/hostap-plx/2.6
+  FILES:= \
+       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
+endef
+
+
+ifeq ($(KERNEL),2.4)
+  define Build/Compile
+       $(MAKE) -C $(LINUX_DIR)/ \
+               ARCH="$(LINUX_KARCH)" \
+               CROSS_COMPILE="$(TARGET_CROSS)" \
+               SUBDIRS="$(PKG_BUILD_DIR)/driver/modules" \
+               modules
+  endef
+else
+  define Build/Prepare
+       mkdir -p $(PKG_BUILD_DIR)
+  endef
+  
+  define Build/Configure
+  endef
+  
+  define Build/Compile
+  endef
+endif
+
+
+$(eval $(call KernelPackage,hostap))
+$(eval $(call KernelPackage,hostap-pci))
+$(eval $(call KernelPackage,hostap-plx))
diff --git a/package/hostap/Makefile b/package/hostap/Makefile
deleted file mode 100644 (file)
index 0b526b6..0000000
+++ /dev/null
@@ -1,133 +0,0 @@
-# 
-# Copyright (C) 2006 OpenWrt.org
-#
-# This is free software, licensed under the GNU General Public License v2.
-# See /LICENSE for more information.
-#
-# $Id$
-
-include $(TOPDIR)/rules.mk
-include $(INCLUDE_DIR)/kernel.mk
-
-PKG_NAME:=hostap-driver
-PKG_VERSION:=0.4.9
-PKG_RELEASE:=1
-
-PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://hostap.epitest.fi/releases/
-PKG_MD5SUM:=c7534dc040ab90218257a78488ecd378
-
-include $(INCLUDE_DIR)/package.mk
-ifeq ($(DUMP),)
-  -include $(LINUX_DIR)/.config
-endif
-
-define KernelPackage/hostap/Default/2.4
-  VERSION:=$(LINUX_VERSION)+$(PKG_VERSION)-$(BOARD)-$(PKG_RELEASE)
-endef
-define KernelPackage/hostap/Default/2.6
-  VERSION:=$(LINUX_VERSION)-$(BOARD)-$(PKG_RELEASE)
-endef
-define KernelPackage/hostap/Default
-  SUBMENU:=Wireless Drivers
-  DESCRIPTION:=\
-       Host AP is a driver for 802.11b wireless cards based on Intersil \\\
-       Prism2/2.5/3 chipset. It supports so called Host AP mode that allows the \\\
-       card to act as an IEEE 802.11 access point.
-  URL:=http://hostap.epitest.fi/
-  $(call KernelPackage/hostap/Default/$(KERNEL))
-endef
-
-
-define KernelPackage/hostap
-  $(call KernelPackage/hostap/Default)
-  DEPENDS:=@PCI_SUPPORT||PCMCIA_SUPPORT +kmod-ieee80211 +kmod-crypto
-  TITLE:=Host AP support for Prism2/2.5/3
-  KCONFIG:=CONFIG_HOSTAP
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the base Host AP driver code that is shared by \\\
-       different hardware models. You will also need to enable support for \\\
-       PLX/PCI/CS version of the driver to actually use the driver.
-endef
-define KernelPackage/hostap/2.4
-  DEPENDS:=+kmod-crypto
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_ccmp.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_tkip.$(LINUX_KMOD_SUFFIX) \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_crypt_wep.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,hostap hostap_crypt_wep hostap_crypt_tkip hostap_crypt_ccmp)
-endef
-define KernelPackage/hostap/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap.$(LINUX_KMOD_SUFFIX)
-  AUTOLOAD:=$(call AutoLoad,60,hostap)
-endef
-
-
-define KernelPackage/hostap-pci
-  $(call KernelPackage/hostap/Default)
-  DEPENDS:=kmod-hostap
-  TITLE:=Host AP driver for PCI adaptors
-  KCONFIG:=CONFIG_HOSTAP_PCI
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the Host AP driver for Prism2.5 PCI adaptors.
-  AUTOLOAD:=$(call AutoLoad,60,hostap_pci)
-endef
-define KernelPackage/hostap-pci/2.4
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_pci.$(LINUX_KMOD_SUFFIX)
-endef
-define KernelPackage/hostap-pci/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_pci.$(LINUX_KMOD_SUFFIX)
-endef
-
-
-define KernelPackage/hostap-plx
-  $(call KernelPackage/hostap/Default)
-  DEPENDS:=kmod-hostap
-  KCONFIG:=CONFIG_HOSTAP_PLX
-  TITLE:=Host AP driver for PLX9052 based PCI adaptors
-  DESCRIPTION+=\\\
-       \\\
-       This package contains the Host AP driver for Prism2/2.5/3 in PLX9052 \\\
-       based PCI adaptors.
-  AUTOLOAD:=$(call AutoLoad,60,hostap_plx)
-endef
-define KernelPackage/hostap-plx/2.4
-  FILES:= \
-       $(PKG_BUILD_DIR)/driver/modules/hostap_plx.$(LINUX_KMOD_SUFFIX)
-endef
-define KernelPackage/hostap-plx/2.6
-  FILES:= \
-       $(LINUX_DIR)/drivers/net/wireless/hostap/hostap_plx.$(LINUX_KMOD_SUFFIX)
-endef
-
-
-ifeq ($(KERNEL),2.4)
-  define Build/Compile
-       $(MAKE) -C $(LINUX_DIR)/ \
-               ARCH="$(LINUX_KARCH)" \
-               CROSS_COMPILE="$(TARGET_CROSS)" \
-               SUBDIRS="$(PKG_BUILD_DIR)/driver/modules" \
-               modules
-  endef
-else
-  define Build/Prepare
-       mkdir -p $(PKG_BUILD_DIR)
-  endef
-  
-  define Build/Configure
-  endef
-  
-  define Build/Compile
-  endef
-endif
-
-
-$(eval $(call KernelPackage,hostap))
-$(eval $(call KernelPackage,hostap-pci))
-$(eval $(call KernelPackage,hostap-plx))