kernel: fix imx sata module
authorLuka Perkov <luka@openwrt.org>
Wed, 11 Sep 2013 22:08:46 +0000 (22:08 +0000)
committerLuka Perkov <luka@openwrt.org>
Wed, 11 Sep 2013 22:08:46 +0000 (22:08 +0000)
The imx sata module has only been backported to imx6 target. This change will
fix buildbot errors due to missing patches in other targets. Keep this until
all targets use kernel version with imx sata support in them.

Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 37950

package/kernel/linux/modules/block.mk

index c5fcb9a6e86cbeb5fead2ed1873aa865bf181a3e..2b6dfacabbea9123fd9737387c736589066e75e9 100644 (file)
@@ -73,7 +73,8 @@ $(eval $(call KernelPackage,ata-artop))
 
 
 define KernelPackage/ata-imx
-  TITLE:=Freescale i.MX6 AHCI SATA support
+  TITLE:=Freescale i.MX AHCI SATA support
+  DEPENDS:=@TARGET_imx6
   KCONFIG:=\
        CONFIG_AHCI_IMX \
        CONFIG_SATA_AHCI_PLATFORM \