imx6: remove redundant IMAGE_NAME
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Feb 2021 15:12:48 +0000 (16:12 +0100)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Mon, 22 Feb 2021 23:26:40 +0000 (00:26 +0100)
IMAGE_NAME is set twice for ventana, and the second value
actually matches the default in image.mk. Remove both.

Fixes: ded905ce431b ("imx6: extend cubox support to hummingboard,
add support for building full images")

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/imx6/image/Makefile

index b520c1f778a9cd04d6d88c6293692165ab8343a5..afc75d6df14488ff77c918aab0b661bb4edf1862 100644 (file)
@@ -164,13 +164,11 @@ define Device/ventana
        kobs-ng
   KERNEL += | boot-overlay
   IMAGES := nand.ubi bootfs.tar.gz dtb
-  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1).$$(2)
   UBINIZE_PARTS = boot=$$(KDIR_KERNEL_IMAGE).boot.ubifs=15
   BOOT_SCRIPT := bootscript-ventana
   IMAGE/nand.ubi := append-ubi
   IMAGE/bootfs.tar.gz := bootfs.tar.gz
   IMAGE/dtb := install-dtb
-  IMAGE_NAME = $$(IMAGE_PREFIX)-$$(1)-$$(2)
   PAGESIZE := 2048
   BLOCKSIZE := 128k
   MKUBIFS_OPTS := -m $$(PAGESIZE) -e 124KiB