ar71xx: refresh patches
authorGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 11:51:15 +0000 (11:51 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Tue, 19 Jun 2012 11:51:15 +0000 (11:51 +0000)
SVN-Revision: 32458

target/linux/ar71xx/patches-3.3/431-spi-add-various-flags.patch
target/linux/ar71xx/patches-3.3/461-spi-add-type-field-to-spi_transfer.patch
target/linux/ar71xx/patches-3.3/616-MIPS-ath79-EW_Dorin-support.patch

index 722f659801578424492dfe351899291d9f5dc0db..67ba43f0cde29d17959d79f9766e061adeda363a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/spi/spi.h
 +++ b/include/linux/spi/spi.h
-@@ -452,6 +452,8 @@ struct spi_transfer {
+@@ -503,6 +503,8 @@ struct spi_transfer {
        dma_addr_t      rx_dma;
  
        unsigned        cs_change:1;
@@ -9,7 +9,7 @@
        u8              bits_per_word;
        u16             delay_usecs;
        u32             speed_hz;
-@@ -493,6 +495,7 @@ struct spi_message {
+@@ -544,6 +546,7 @@ struct spi_message {
        struct spi_device       *spi;
  
        unsigned                is_dma_mapped:1;
index 3c7e98169d65e9dc45704c3d4bd0ca28db5a50bd..850f24a07ade1f2a1474f9bb4d9782d2ac63fee2 100644 (file)
@@ -1,6 +1,6 @@
 --- a/include/linux/spi/spi.h
 +++ b/include/linux/spi/spi.h
-@@ -355,6 +355,12 @@ extern struct spi_master *spi_busnum_to_
+@@ -406,6 +406,12 @@ extern struct spi_master *spi_busnum_to_
  
  /*---------------------------------------------------------------------------*/
  
@@ -13,7 +13,7 @@
  /*
   * I/O INTERFACE between SPI controller and protocol drivers
   *
-@@ -457,6 +463,7 @@ struct spi_transfer {
+@@ -508,6 +514,7 @@ struct spi_transfer {
        u8              bits_per_word;
        u16             delay_usecs;
        u32             speed_hz;
index 09a9764b9c94ac518a750ac4ffb2592d5b8ad7eb..486f6e56aabddc256a7cae41b4bf638ff00f7a8d 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -240,6 +240,18 @@
+@@ -240,6 +240,18 @@ config ATH79_MACH_DIR_825_B1
        select ATH79_DEV_M25P80
        select ATH79_DEV_USB
  
@@ -21,7 +21,7 @@
        select SOC_AR71XX
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -32,6 +32,7 @@
+@@ -32,6 +32,7 @@ enum ath79_mach_type {
        ATH79_MACH_DIR_615_C1,          /* D-Link DIR-615 rev. C1 */
        ATH79_MACH_DIR_615_E4,          /* D-Link DIR-615 rev. E4 */
        ATH79_MACH_DIR_825_B1,          /* D-Link DIR-825 rev. B1 */
@@ -31,7 +31,7 @@
        ATH79_MACH_JA76PF2,             /* jjPlus JA76PF2 */
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -49,6 +49,7 @@
+@@ -49,6 +49,7 @@ obj-$(CONFIG_ATH79_MACH_DB120)               += mach-
  obj-$(CONFIG_ATH79_MACH_DIR_600_A1)   += mach-dir-600-a1.o
  obj-$(CONFIG_ATH79_MACH_DIR_615_C1)   += mach-dir-615-c1.o
  obj-$(CONFIG_ATH79_MACH_DIR_825_B1)   += mach-dir-825-b1.o