madwifi: Fix linux 3.0 detection
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 15 Jun 2011 21:17:17 +0000 (21:17 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 15 Jun 2011 21:17:17 +0000 (21:17 +0000)
Allows madwifi to be built against linux 3.0.

Signed-off-by: Jonas Gorski <jonas.gorski+openwrt@gmail.com>
SVN-Revision: 27188

package/madwifi/patches/476-3.0_detection_fix.patch [new file with mode: 0644]

diff --git a/package/madwifi/patches/476-3.0_detection_fix.patch b/package/madwifi/patches/476-3.0_detection_fix.patch
new file mode 100644 (file)
index 0000000..2f8bfb4
--- /dev/null
@@ -0,0 +1,25 @@
+--- a/Makefile
++++ b/Makefile
+@@ -155,13 +155,15 @@ unload:
+ configcheck:
+       @echo -n "Checking kernel configuration... "
+       
+-      @# check version of kernel
+-      @echo $(KERNELRELEASE) | grep -q -i '^[2-9]\.[4-9]\.' || { \
+-          echo "FAILED"; \
+-          echo "Only kernel versions 2.4.x and above are supported."; \
+-          echo "You have $(KERNELRELEASE)."; \
+-          exit 1; \
+-      }
++      @# check kernel version
++      @case $(KERNELRELEASE) in \
++          2.[456].*) ;; \
++          [3-9].*) ;; \
++          *) echo "FAILED"; \
++             echo "Only kernel versions 2.4.x and above are supported."; \
++             echo "You have $(KERNELRELEASE)."; \
++             exit 1 ;; \
++      esac
+       
+       @# check kernel configuration
+       @if [ -z "$(CONFIG_SYSCTL)" ]; then \