ipq40xx: set IMAGES in Device/Default definition
authorAdrian Schmutzler <freifunk@adrianschmutzler.de>
Wed, 24 Jun 2020 17:40:45 +0000 (19:40 +0200)
committerAdrian Schmutzler <freifunk@adrianschmutzler.de>
Sun, 28 Jun 2020 12:07:43 +0000 (14:07 +0200)
The Device/Default definition sets a default IMAGE/sysupgrade.bin,
but does not enable it by setting IMAGES. This is not consistent,
and has led to IMAGES being defined at various other places in the
file.

Thus, this patch consolidates the default value for IMAGES by putting
it in Device/Default. Since it's still overwritten where necessary,
this patch is cosmetic.

Signed-off-by: Adrian Schmutzler <freifunk@adrianschmutzler.de>
target/linux/ipq40xx/image/Makefile

index 632836e94fab07d010fb64bc00f01102e2f60703..a374c7da4735bbd897ecc04080d0ebf02f28c250 100644 (file)
@@ -13,6 +13,7 @@ define Device/Default
        KERNEL_LOADADDR := 0x80208000
        DEVICE_DTS = $$(SOC)-$(lastword $(subst _, ,$(1)))
        SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin = sysupgrade-tar | append-metadata
        IMAGE/sysupgrade.bin/squashfs :=
 endef
@@ -46,7 +47,7 @@ define Device/DniImage
        $(call Device/FitzImage)
        NETGEAR_BOARD_ID :=
        NETGEAR_HW_ID :=
-       IMAGES := factory.img sysupgrade.bin
+       IMAGES += factory.img
        IMAGE/factory.img := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | append-rootfs | pad-rootfs | netgear-dni
        IMAGE/sysupgrade.bin := append-kernel | pad-offset 64k 64 | append-uImage-fakehdr filesystem | \
                append-rootfs | pad-rootfs | append-metadata | check-size
@@ -110,7 +111,6 @@ define Device/8dev_habanero-dvk
        IMAGE_SIZE := 30976k
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := ipq-wifi-8dev_habanero-dvk
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | pad-to 64k | append-rootfs | pad-rootfs | append-metadata | check-size
 endef
 TARGET_DEVICES += 8dev_habanero-dvk
@@ -151,7 +151,6 @@ define Device/aruba_glenmorangie
        DEVICE_VENDOR := Aruba
        SOC := qcom-ipq4029
        DEVICE_PACKAGES := ipq-wifi-aruba_ap-303
-       IMAGES := sysupgrade.bin
 endef
 
 define Device/aruba_ap-303
@@ -178,7 +177,6 @@ define Device/asus_map-ac2200
        DEVICE_VENDOR := ASUS
        DEVICE_MODEL := Lyra (MAP-AC2200)
        SOC := qcom-ipq4019
-       IMAGES := sysupgrade.bin
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct kmod-ath3k
 endef
 TARGET_DEVICES += asus_map-ac2200
@@ -199,7 +197,6 @@ define Device/asus_rt-ac58u
 #      to add a version... or we are very careful not to add '\0' into that
 #      string and call it a day.... Yeah, we do the latter!
        UIMAGE_NAME:=$(shell echo -e '\03\01\01\01RT-AC58U')
-       IMAGES := sysupgrade.bin
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
                kmod-usb-ledtrig-usbport
 endef
@@ -214,7 +211,7 @@ define Device/avm_fritzbox-4040
        IMAGE_SIZE := 29056k
        UBOOT_PATH := $(STAGING_DIR_IMAGE)/uboot-fritz4040.bin
        UBOOT_PARTITION_SIZE := 524288
-       IMAGES = eva.bin sysupgrade.bin
+       IMAGES += eva.bin
        IMAGE/eva.bin := append-uboot | pad-to $$$$(UBOOT_PARTITION_SIZE) | append-kernel | append-rootfs | pad-rootfs
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
        DEVICE_PACKAGES := fritz-tffs fritz-caldata
@@ -227,7 +224,6 @@ define Device/avm_fritzbox-7530
        DEVICE_MODEL := FRITZ!Box 7530
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand
-       IMAGES := sysupgrade.bin
 endef
 TARGET_DEVICES += avm_fritzbox-7530
 
@@ -237,7 +233,6 @@ define Device/avm_fritzrepeater-1200
        DEVICE_MODEL := FRITZ!Repeater 1200
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := fritz-caldata fritz-tffs-nand ipq-wifi-avm_fritzrepeater-1200
-       IMAGES := sysupgrade.bin
 endef
 TARGET_DEVICES += avm_fritzrepeater-1200
 
@@ -247,7 +242,6 @@ define Device/avm_fritzrepeater-3000
        DEVICE_MODEL := FRITZ!Repeater 3000
        SOC := qcom-ipq4019
        DEVICE_PACKAGES := ath10k-firmware-qca9984-ct fritz-caldata fritz-tffs-nand
-       IMAGES := sysupgrade.bin
 endef
 TARGET_DEVICES += avm_fritzrepeater-3000
 
@@ -304,7 +298,7 @@ define Device/compex_wpj428
        BLOCKSIZE := 64k
        IMAGE_SIZE := 31232k
        KERNEL_SIZE := 4096k
-       IMAGES = sysupgrade.bin cpximg-6a04.bin
+       IMAGES += cpximg-6a04.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/cpximg-6a04.bin := append-kernel | append-rootfs | pad-rootfs | mkmylofw_32m 0x8A2 3
        DEVICE_PACKAGES := kmod-gpio-beeper
@@ -321,7 +315,7 @@ define Device/dlink_dap-2610
        WRGG_DEVNAME := /dev/mtdblock/8
        WRGG_SIGNATURE := wapac30_dkbs_dap2610
        IMAGE_SIZE := 14080k
-       IMAGES := sysupgrade.bin factory.bin
+       IMAGES += factory.bin
        # Bootloader expects a special 160 byte header which is added by
        # wrgg-image.
        # Factory image size must be larger than 6MB, and size in wrgg header must
@@ -347,7 +341,6 @@ define Device/engenius_eap1300
        SOC := qcom-ipq4018
        KERNEL_SIZE := 5120k
        IMAGE_SIZE := 25344k
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += engenius_eap1300
@@ -371,7 +364,7 @@ define Device/engenius_emd1
        DEVICE_DTS_CONFIG := config@4
        SOC := qcom-ipq4018
        IMAGE_SIZE := 30720k
-       IMAGES := sysupgrade.bin factory.bin
+       IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
 endef
@@ -385,7 +378,7 @@ define Device/engenius_emr3500
        SOC := qcom-ipq4018
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 30720k
-       IMAGES := sysupgrade.bin factory.bin
+       IMAGES += factory.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        IMAGE/factory.bin := qsdk-ipq-factory-nor | check-size
 endef
@@ -410,7 +403,7 @@ define Device/engenius_ens620ext
        IMAGE_SIZE := 21312k
        KERNEL_SIZE := 5120k
        FILESYSTEMS := squashfs
-       IMAGES := sysupgrade.bin factory_30.bin factory_35.bin
+       IMAGES += factory_30.bin factory_35.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | check-size | append-metadata
        IMAGE/factory_30.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | check-size | SenaoFW $$$$(PRODUCT_ID) $$$$(FW_VER)
        IMAGE/factory_35.bin := qsdk-ipq-factory-nor | check-size | SenaoFW $$$$(PRODUCT_ID_NEW) $$$$(FW_VER_NEW)
@@ -425,7 +418,6 @@ define Device/ezviz_cs-w3-wd1200g-eup
        DEVICE_DTS_CONFIG := config@4
        IMAGE_SIZE := 14848k
        SOC := qcom-ipq4018
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | \
                append-metadata
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers \
@@ -441,7 +433,6 @@ define Device/glinet_gl-b1300
        SOC := qcom-ipq4029
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 26624k
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel |append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += glinet_gl-b1300
@@ -477,7 +468,7 @@ define Device/linksys_ea6350v3
        KERNEL_SIZE := 3072k
        IMAGE_SIZE := 37888k
        UBINIZE_OPTS := -E 5
-       IMAGES := factory.bin sysupgrade.bin
+       IMAGES += factory.bin
        IMAGE/factory.bin := append-kernel | append-uImage-fakehdr filesystem | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA6350v3
        DEVICE_PACKAGES := uboot-envtools
 endef
@@ -493,7 +484,7 @@ define Device/linksys_ea8300
        BLOCKSIZE := 128k
        PAGESIZE := 2048
        UBINIZE_OPTS := -E 5    # EOD marks to "hide" factory sig at EOF
-       IMAGES := sysupgrade.bin factory.bin
+       IMAGES += factory.bin
        IMAGE/factory.bin  := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-ubi | linksys-image type=EA8300
        DEVICE_PACKAGES := uboot-envtools ath10k-firmware-qca9888-ct ipq-wifi-linksys_ea8300 kmod-usb-ledtrig-usbport
 endef
@@ -506,7 +497,6 @@ define Device/meraki_mr33
        SOC := qcom-ipq4029
        BLOCKSIZE := 128k
        PAGESIZE := 2048
-       IMAGES = sysupgrade.bin
        DEVICE_PACKAGES := -swconfig ath10k-firmware-qca9887-ct
 endef
 TARGET_DEVICES += meraki_mr33
@@ -557,7 +547,7 @@ define Device/openmesh_a42
        BLOCKSIZE := 64k
        KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15616k
-       IMAGES = factory.bin sysupgrade.bin
+       IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A42
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
        DEVICE_PACKAGES := uboot-envtools
@@ -573,7 +563,7 @@ define Device/openmesh_a62
        BLOCKSIZE := 64k
        KERNEL = kernel-bin | lzma | fit lzma $$(DTS_DIR)/$$(DEVICE_DTS).dtb | pad-to $$(BLOCKSIZE)
        IMAGE_SIZE := 15552k
-       IMAGES = factory.bin sysupgrade.bin
+       IMAGES += factory.bin
        IMAGE/factory.bin := append-rootfs | pad-rootfs | openmesh-image ce_type=A62
        IMAGE/sysupgrade.bin/squashfs := append-rootfs | pad-rootfs | sysupgrade-tar rootfs=$$$$@ | append-metadata
        DEVICE_PACKAGES := ath10k-firmware-qca9888-ct uboot-envtools
@@ -592,7 +582,6 @@ define Device/qcom_ap-dk01.1-c1
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 26624k
        $(call Device/FitImage)
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | pad-to $$$$(KERNEL_SIZE) | append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += qcom_ap-dk01.1-c1
@@ -622,7 +611,6 @@ define Device/qxwlan_e2600ac-c1
        SOC := qcom-ipq4019
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 31232k
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
        DEVICE_PACKAGES := ipq-wifi-qxwlan_e2600ac
 endef
@@ -651,7 +639,6 @@ define Device/unielec_u4019-32m
        SOC := qcom-ipq4019
        KERNEL_SIZE := 4096k
        IMAGE_SIZE := 31232k
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
 endef
 TARGET_DEVICES += unielec_u4019-32m
@@ -667,7 +654,7 @@ define Device/zyxel_nbg6617
        RAS_ROOTFS_SIZE := 19840k
        RAS_VERSION := "$(VERSION_DIST) $(REVISION)"
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata
-       IMAGES := sysupgrade.bin factory.bin
+       IMAGES += factory.bin
 #      The ZyXEL firmware allows flashing thru the web-gui only when the rootfs is
 #      at least as large as the one of the initial firmware image (not the current
 #      one on the device). This only applies to the Web-UI, the bootlaoder ignores
@@ -685,7 +672,6 @@ define Device/zyxel_wre6606
        DEVICE_DTS_CONFIG := config@4
        SOC := qcom-ipq4018
        IMAGE_SIZE := 13184k
-       IMAGES := sysupgrade.bin
        IMAGE/sysupgrade.bin := append-kernel | append-rootfs | pad-rootfs | append-metadata | check-size
        DEVICE_PACKAGES := -kmod-ath10k-ct kmod-ath10k-ct-smallbuffers
 endef