ath79: lzma-loader: fix & re-enable per-board CONFIG_BOARD_DEV
authorChristian Lamparter <chunkeey@gmail.com>
Sat, 31 Jul 2021 20:56:29 +0000 (22:56 +0200)
committerChristian Lamparter <chunkeey@gmail.com>
Fri, 22 Oct 2021 19:25:18 +0000 (21:25 +0200)
Back in the AR71XX days, the lzma-loader code could be customized
based on the $BOARD variable. These would be passed as a
compile-time -DCONFIG_BOARD_$DEVICE_MODEL flag to the compiler.
Hence, the lzma-loader would be able to include device-specific
fixups.

Note: There's still a fixup for the TpLink TL-WR1043ND V1 found
in the lzma-loader's board.c code. But since the days of AR71XX
I couldn't find a forum post or bug reported. So, I left it
as is to not break anything by enabling it.

=> If you have a TL-WR1043ND V1 and you have problem with
the ethernet: let me know. Because otherwise, the fixup
might simply no longer needed with ath79 and it can be removed.

Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/ath79/image/Makefile

index 38c623bf2733f9dae2cd1c447f3532e719f5279e..768ec570449049489f0350dbd86784fbf1bf65a7 100644 (file)
@@ -27,14 +27,17 @@ define Build/loader-common
 endef
 
 define Build/loader-kernel
-       $(call Build/loader-common,LOADER_DATA="$@")
+       $(call Build/loader-common, \
+               LOADER_DATA="$@" \
+               BOARD="$(DEVICE_NAME)" )
 endef
 
 define Build/loader-okli-compile
        $(call Build/loader-common, \
                FLASH_OFFS=$(LOADER_FLASH_OFFS) \
                FLASH_MAX=$(LOADER_FLASH_MAX) \
-               KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) )
+               KERNEL_MAGIC=$(LOADER_KERNEL_MAGIC) \
+               BOARD="$(DEVICE_NAME)" )
 endef
 
 # Arguments: <output name> <kernel offset>