kernel: update to 3.7 final
authorFlorian Fainelli <florian@openwrt.org>
Tue, 11 Dec 2012 11:31:17 +0000 (11:31 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 11 Dec 2012 11:31:17 +0000 (11:31 +0000)
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 34626

include/kernel-version.mk
target/linux/generic/patches-3.7/067-input_keymap_module_license.patch [deleted file]

index 664c98dce4dbcacea1cb6e4d883efcbc89407d39..75d4f967494e365067be5f9d0b6340556a2a9776 100644 (file)
@@ -8,6 +8,9 @@ endif
 ifeq ($(LINUX_VERSION),3.6.9)
   LINUX_KERNEL_MD5SUM:=f77bac0a8f499f221d13a69317145610
 endif
+ifeq ($(LINUX_VERSION),3.7)
+  LINUX_KERNEL_MD5SUM:=21223369d682bcf44bcdfe1521095983
+endif
 
 # disable the md5sum check for unknown kernel versions
 LINUX_KERNEL_MD5SUM?=x
diff --git a/target/linux/generic/patches-3.7/067-input_keymap_module_license.patch b/target/linux/generic/patches-3.7/067-input_keymap_module_license.patch
deleted file mode 100644 (file)
index 4023042..0000000
+++ /dev/null
@@ -1,39 +0,0 @@
-From 07b9a6cde27d690ea3331fc2ca2778902d929aaa Mon Sep 17 00:00:00 2001
-From: Florian Fainelli <florian@openwrt.org>
-Date: Mon, 10 Dec 2012 20:55:54 +0100
-Subject: [PATCH] Input: matrix-keymap - provide a proper module license
-
-The matrix-keymap module is currently lacking a proper module license,
-add one so we don't have this module tainting the entire kernel. This
-issue has been present since commit 1932811f (Input: matrix-keymap -
-uninline and prepare for device tree support)
-
-Signed-off-by: Florian Fainelli <florian@openwrt.org>
-CC: stable@vger.kernel.org
----
-Dmitry, can you try to push this to Linus before 3.7 final? Thank you
-
- drivers/input/matrix-keymap.c |    3 +++
- 1 file changed, 3 insertions(+)
-
-diff --git a/drivers/input/matrix-keymap.c b/drivers/input/matrix-keymap.c
-index 443ad64b..d88d9be 100644
---- a/drivers/input/matrix-keymap.c
-+++ b/drivers/input/matrix-keymap.c
-@@ -23,6 +23,7 @@
- #include <linux/input.h>
- #include <linux/of.h>
- #include <linux/export.h>
-+#include <linux/module.h>
- #include <linux/input/matrix_keypad.h>
- static bool matrix_keypad_map_key(struct input_dev *input_dev,
-@@ -161,3 +162,5 @@ int matrix_keypad_build_keymap(const struct matrix_keymap_data *keymap_data,
-       return 0;
- }
- EXPORT_SYMBOL(matrix_keypad_build_keymap);
-+
-+MODULE_LICENSE("GPL");
--- 
-1.7.10.4
-