kernel: bump 4.4 to 4.4.111 for 17.01
authorKevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
Wed, 10 Jan 2018 16:01:00 +0000 (16:01 +0000)
committerJohn Crispin <john@phrozen.org>
Wed, 17 Jan 2018 09:35:08 +0000 (10:35 +0100)
Refresh patches

Tested-on: ar71xx Archer C7 v2

Signed-off-by: Kevin Darbyshire-Bryant <ldir@darbyshire-bryant.me.uk>
include/kernel-version.mk
target/linux/generic/patches-4.4/204-module_strip.patch
target/linux/generic/patches-4.4/902-debloat_proc.patch

index c6231ce8702f5139d5a47344ae0a897161ec57e5..0af24b41701b1816c7c5d0a71e1ac078ac64bcf1 100644 (file)
@@ -3,10 +3,10 @@
 LINUX_RELEASE?=1
 
 LINUX_VERSION-3.18 = .43
-LINUX_VERSION-4.4 = .110
+LINUX_VERSION-4.4 = .111
 
 LINUX_KERNEL_HASH-3.18.43 = 1236e8123a6ce537d5029232560966feed054ae31776fe8481dd7d18cdd5492c
-LINUX_KERNEL_HASH-4.4.110 = d099175aac5678e6cad2f23cd56ed22a2857143c0c18489390c95ba8c441db58
+LINUX_KERNEL_HASH-4.4.111 = a201282e8eaf62b4f51edb2241e98ff805fe2d1b04a72a2328c5a6e2d77ec008
 
 ifdef KERNEL_PATCHVER
   LINUX_VERSION:=$(KERNEL_PATCHVER)$(strip $(LINUX_VERSION-$(KERNEL_PATCHVER)))
index 85805b3ea1c4960efa1d0601e57e8f5dc501ec61..d4c8039f755e620d1c835ac7c6946d563b8bd166 100644 (file)
@@ -105,7 +105,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  config MODULES_TREE_LOOKUP
 --- a/kernel/module.c
 +++ b/kernel/module.c
-@@ -2864,6 +2864,7 @@ static struct module *setup_load_info(st
+@@ -2871,6 +2871,7 @@ static struct module *setup_load_info(st
  
  static int check_modinfo(struct module *mod, struct load_info *info, int flags)
  {
@@ -113,7 +113,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        const char *modmagic = get_modinfo(info, "vermagic");
        int err;
  
-@@ -2889,6 +2890,7 @@ static int check_modinfo(struct module *
+@@ -2900,6 +2901,7 @@ static int check_modinfo(struct module *
                pr_warn("%s: module is from the staging directory, the quality "
                        "is unknown, you have been warned.\n", mod->name);
        }
index 248ba8f670faa7a886c3ad6c275803c4b8040dec..f7718bc5bf3559a3a48b9ed7e6d340900792a414 100644 (file)
  }
 --- a/mm/vmstat.c
 +++ b/mm/vmstat.c
-@@ -1556,10 +1556,12 @@ static int __init setup_vmstat(void)
+@@ -1558,10 +1558,12 @@ static int __init setup_vmstat(void)
        cpu_notifier_register_done();
  #endif
  #ifdef CONFIG_PROC_FS