compile libnl with -ffunction-sections to make binaries that use genl smaller
authorFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jun 2008 17:55:21 +0000 (17:55 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jun 2008 17:55:21 +0000 (17:55 +0000)
SVN-Revision: 11600

package/libnl/Makefile

index a6dec002b37c251158c9e94e2809d08e211c4398..88776a07e92c57b6812ab910e6af7652e0830674 100644 (file)
@@ -29,6 +29,8 @@ define Package/libnl/description
  This package contains a library for applications dealing with netlink sockets
 endef
 
+TARGET_CFLAGS += -ffunction-sections
+
 define Build/Compile
        $(call Build/Compile/Default)
        make -C $(PKG_BUILD_DIR) \