kernel: add w1-master-mxc module
authorLuka Perkov <luka@openwrt.org>
Tue, 29 Oct 2013 02:52:17 +0000 (02:52 +0000)
committerLuka Perkov <luka@openwrt.org>
Tue, 29 Oct 2013 02:52:17 +0000 (02:52 +0000)
Signed-off-by: Luka Perkov <luka@openwrt.org>
SVN-Revision: 38575

package/kernel/linux/modules/w1.mk

index a85c22f5d2062cef392cbf0a9a59a1f063328db2..c2fc6495d46c4187c40b4f4a557449c4d8a4644e 100644 (file)
@@ -79,6 +79,23 @@ endef
 
 $(eval $(call KernelPackage,w1-master-ds2490))
 
+
+define KernelPackage/w1-master-mxc
+  TITLE:=Freescale MXC 1-wire busmaster
+  DEPENDS:=@(TARGET_mxs||TARGET_imx6)
+  KCONFIG:=CONFIG_W1_MASTER_MXC
+  FILES:=$(W1_MASTERS_DIR)/mxc_w1.ko
+  AUTOLOAD:=$(call AutoProbe,mxc_w1)
+  $(call AddDepends/w1)
+endef
+
+define KernelPackage/w1-master-mxc/description
+ Kernel module for 1-wire Freescale MXC 1-wire busmaster
+endef
+
+$(eval $(call KernelPackage,w1-master-mxc))
+
+
 #
 # 1-wire slaves
 #