imx6: optimize for NEON FPU hardware
authorLuka Perkov <luka@openwrt.org>
Thu, 27 Feb 2014 22:41:40 +0000 (22:41 +0000)
committerLuka Perkov <luka@openwrt.org>
Thu, 27 Feb 2014 22:41:40 +0000 (22:41 +0000)
The IMX6 SoC uses an ARM Cortext-A9 which has both NEON and VFPv3 hardware
blocks.  This will tune gcc to use neon instead of vfpv3 which will outperform
VFPv3.

Signed-off-by: Tim Harvey <tharvey@gateworks.com>
SVN-Revision: 39760

target/linux/imx6/Makefile

index cee5b45423827768dd6aba6042ad95e2a4aec9ce..688e35539351c02ca48157ee8d93ede383fc6c4a 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=imx6
 BOARDNAME:=Freescale i.MX 6 Series
 FEATURES:=audio display fpu gpio pcie rtc usb usbgadget squashfs targz ubifs
 CPU_TYPE:=cortex-a9
-CPU_SUBTYPE:=vfpv3
+CPU_SUBTYPE:=neon
 MAINTAINER:=Luka Perkov <luka@openwrt.org>
 
 LINUX_VERSION:=3.10.32