lantiq: fix VG3503J partition table for newer kernels
authorJohn Crispin <john@openwrt.org>
Wed, 11 Feb 2015 10:17:38 +0000 (10:17 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 11 Feb 2015 10:17:38 +0000 (10:17 +0000)
the kernel has increased and does not fit into the 1,5MB anymore.

Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 44391

target/linux/lantiq/dts/VG3503J.dtsi
target/linux/lantiq/image/Makefile

index 3e6bab5dd37065b1edd8c7fb0efaac2542fac40e..cebc4a49ca4a02979901c2ad466bf7a1d40f8499 100644 (file)
 
                                partition@20000 {
                                        label = "kernel";
-                                       reg = <0x20000 0x180000>;
+                                       reg = <0x20000 0x300000>;
                                };
 
                                partition@1a0000 {
                                        label = "rootfs";
-                                       reg = <0x1a0000 0x5a0000>;
+                                       reg = <0x1a0000 0x420000>;
                                };
 
                                partition@740000 {
index 82f0e6f3272c50a56afcd96a8a6eb549785a9455..08d80ecb1d80486068b5e8ec9e0c4c1ccb9c44d6 100644 (file)
@@ -156,7 +156,7 @@ endif
 endef
 
 define Image/BuildLoader/squashfs
-       dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=1536k conv=sync
+       dd if=$(KDIR)/loader-$(2).bin of=$(KDIR)/loader-$(2).bin.padded bs=3072k conv=sync
        cat $(KDIR)/loader-$(2).bin.padded $(KDIR)/root.$(1) > $(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image
        $(call prepare_generic_squashfs,$(BIN_DIR)/$(IMG_PREFIX)-$(2)-$(1).image)
 endef