brcm63xx: move V2110 to DT
authorJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:20:49 +0000 (20:20 +0000)
committerJonas Gorski <jogo@openwrt.org>
Mon, 30 Mar 2015 20:20:49 +0000 (20:20 +0000)
Also readd image generation which was accidentally dropped in r43364.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 45165

25 files changed:
target/linux/brcm63xx/base-files/lib/brcm63xx.sh
target/linux/brcm63xx/dts/v2110.dts [new file with mode: 0644]
target/linux/brcm63xx/image/Makefile
target/linux/brcm63xx/patches-3.18/512-board_BTV2110.patch
target/linux/brcm63xx/patches-3.18/514-board_ct536_ct5621.patch
target/linux/brcm63xx/patches-3.18/516-board_96348A-122.patch
target/linux/brcm63xx/patches-3.18/519_board_CPVA502plus.patch
target/linux/brcm63xx/patches-3.18/520-bcm63xx-add-support-for-96368MVWG-board.patch
target/linux/brcm63xx/patches-3.18/521-bcm63xx-add-support-for-96368MVNgr-board.patch
target/linux/brcm63xx/patches-3.18/525-board_96348w3.patch
target/linux/brcm63xx/patches-3.18/526-board_CT6373-1.patch
target/linux/brcm63xx/patches-3.18/527-board_dva-g3810bn-tl-1.patch
target/linux/brcm63xx/patches-3.18/528-board_nb6.patch
target/linux/brcm63xx/patches-3.18/529-board_fast2604.patch
target/linux/brcm63xx/patches-3.18/534-board_hw556.patch
target/linux/brcm63xx/patches-3.18/537-board_fast2504n.patch
target/linux/brcm63xx/patches-3.18/560-board_963268gu_p300.patch
target/linux/brcm63xx/patches-3.18/561-board_WAP-5813n.patch
target/linux/brcm63xx/patches-3.18/562-board_VR-3025u.patch
target/linux/brcm63xx/patches-3.18/563-board_VR-3025un.patch
target/linux/brcm63xx/patches-3.18/564-board_P870HW-51a_v2.patch
target/linux/brcm63xx/patches-3.18/565-board_hw520.patch
target/linux/brcm63xx/patches-3.18/568-board_DGND3700v1_3800B.patch
target/linux/brcm63xx/patches-3.18/569-board_homehub2a.patch
target/linux/brcm63xx/profiles/bt.mk

index 90d3e73378e1e6cb32c4a78903e3ffbd257754e6..1930e37a25b1b33c8f9b9cc42ddcff76950fd1db 100755 (executable)
@@ -66,6 +66,9 @@ brcm63xx_dt_detect() {
        "BT Home Hub 2.0 Type A")
                board_name="homehub2a"
                ;;
+       "BT Voyager 2110")
+               board_name="v2110"
+               ;;
        "BT Voyager V2500V")
                board_name="v2500v_bb"
                ;;
@@ -228,9 +231,6 @@ brcm63xx_legacy_detect() {
        local board_name
 
        case "$1" in
-       V2110)
-               board_name="v2110"
-               ;;
        VW6339GU)
                board_namge="vg50"
                ;;
diff --git a/target/linux/brcm63xx/dts/v2110.dts b/target/linux/brcm63xx/dts/v2110.dts
new file mode 100644 (file)
index 0000000..0721d24
--- /dev/null
@@ -0,0 +1,69 @@
+/dts-v1/;
+
+/include/ "bcm6348.dtsi"
+
+/ {
+       model = "BT Voyager 2110";
+       compatible = "bt,v2110", "brcm,bcm6348";
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+               debounce-interval = <60>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 1 1>;
+                       linux,code = <0x198>;
+               };
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               power_green {
+                       label = "V2110:green:power";
+                       gpios = <&gpio0 0 1>;
+               };
+               power_red {
+                       label = "V2110:red:power";
+                       gpios = <&gpio0 1 1>;
+               };
+               adsl_green {
+                       label = "V2110:green:adsl";
+                       gpios = <&gpio0 2 1>;
+               };
+               ppp_green {
+                       label = "V2110:green:ppp";
+                       gpios = <&gpio0 3 1>;
+               };
+               wireless_green {
+                       label = "V2110:green:wireless";
+                       gpios = <&gpio0 6 1>;
+               };
+       };
+};
+
+&pflash {
+       status = "ok";
+
+       linux,part-probe = "bcm63xxpart";
+
+       cfe@0 {
+               label = "CFE";
+               reg = <0x000000 0x010000>;
+               read-only;
+       };
+
+       linux@10000 {
+               label = "linux";
+               reg = <0x010000 0x3e0000>;
+       };
+
+       nvram@3f0000 {
+               label = "nvram";
+               reg = <0x3f0000 0x010000>;
+       };
+};
index 9f5d68204cf4b3d8d0ef8239f9a4482c74caa806..c71fc0a4553ccc043db46cbe92abc26fc6e0c19f 100755 (executable)
@@ -302,6 +302,8 @@ $(eval $(call ImageDTB,CFEDTB,F5D7633,F5D7633,f5d7633,96348GW-10,6348,--block-si
 $(eval $(call ImageDTB,Dummy,BCM963268BU_P300,BCM963268BU_P300,bcm963268bu_p300,963268BU_P300,63268))
 # BT Home Hub 2.0 A
 $(eval $(call ImageDTB,CFEDTB,BTHOMEHUB2A,HomeHub2A,homehub2a,HOMEHUB2A,6358,--image-offset 0x20000 --block-size 0x20000))
+# BT Voyager V2110, V2110_AA, V2110_ROI
+$(eval $(call ImageDTB,CFEDTB,BTV2110,BTV2110,v2110,V2110,6348,--layoutver 5))
 # BT Voyager V2500V, V2500V_SIP_CLUB, V2500V_AA
 $(eval $(call ImageDTB,CFEDTB,BTV2500V,BTV2500V,v2500v-bb,V2500V_BB,6348,--layoutver 5))
 # Comtrend AR-5381u
index 8283174775ff9027e53c2f1148e24b531a76b97b..d316fd4b6a8c193c9eee356d5bc01a1456968933 100644 (file)
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
+@@ -1087,6 +1107,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "brcm,bcm96348gw-10", .data = &board_96348gw_10, },
+       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
++      { .compatible = "bt,v2110", .data = &board_V2110, },
+       { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
+       { .compatible = "d-link,dsl-2640b-b", .data = &board_96348_D4PW, },
+       { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
index 41e9620f19a6467ce62c8ea24936a0bac49a1802..a3ac4ced75ae8dc9858d78b39f7c6988c5445cdf 100644 (file)
@@ -43,9 +43,9 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1108,6 +1137,8 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-11", .data = &board_96348gw_11, },
+@@ -1109,6 +1138,8 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+       { .compatible = "bt,v2110", .data = &board_V2110, },
        { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
 +      { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5621", .data = &board_ct536_ct5621, },
index b90c6086bb97148939bca7669dc5a3ad909583b2..3d68881c83bbf630f082ee26dc209c26ab4d8757 100644 (file)
@@ -40,8 +40,8 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1141,6 +1167,7 @@ static struct of_device_id const bcm963x
-       { .compatible = "brcm,bcm96348gw-a", .data = &board_96348gw_a, },
+@@ -1142,6 +1168,7 @@ static struct of_device_id const bcm963x
+       { .compatible = "bt,v2110", .data = &board_V2110, },
        { .compatible = "bt,v2500v-bb", .data = &board_V2500V_BB, },
        { .compatible = "comtrend,ct-536+", .data = &board_ct536_ct5621, },
 +      { .compatible = "comtrend,ct-5365", .data = &board_96348A_122, },
index 1eed2c15c068a8a82b61c9537052bcf8de9f4196..c6e4e376b96425a7636731df25a4c85e19c65bf6 100644 (file)
@@ -36,7 +36,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1178,6 +1200,7 @@ static struct of_device_id const bcm963x
+@@ -1179,6 +1201,7 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw500v", .data = &board_spw500v, },
        { .compatible = "tecom,gw6000", .data = &board_gw6000, },
        { .compatible = "tecom,gw6200", .data = &board_gw6200, },
index 86d29cbda0bc0d746d66ae1858b8e632730db580..4e9ce3b9dc90650e0e767ddc8eb2ee8b92050692 100644 (file)
@@ -81,7 +81,7 @@ Subject: [PATCH 32/63] bcm63xx: add support for 96368MVWG board.
  };
  
  static struct of_device_id const bcm963xx_boards_dt[] = {
-@@ -1222,6 +1279,7 @@ static struct of_device_id const bcm963x
+@@ -1223,6 +1280,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index 433fdb63fea41b61a6ce56ab3fcc5b67742bb890..2914ef13c41de0c7a7c4029676680f1f9f3085b8 100644 (file)
@@ -64,7 +64,7 @@ Subject: [PATCH 33/63] bcm63xx: add support for 96368MVNgr board.
  #endif
  };
  
-@@ -1279,6 +1320,7 @@ static struct of_device_id const bcm963x
+@@ -1280,6 +1321,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6368
index fade962bfb3b9ca34f5912edf158525bebaba8b8..1089eeda6dd68684794b3c6faf4584e7b7d59520 100644 (file)
@@ -34,7 +34,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6358
-@@ -1405,6 +1425,7 @@ static struct of_device_id const bcm963x
+@@ -1406,6 +1426,7 @@ static struct of_device_id const bcm963x
        { .compatible = "davolink,dv-201amr", .data = &board_DV201AMR, },
        { .compatible = "dynalink,rta1025w", .data = &board_rta1025w_16, },
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
index 5c2dabe5b1944399fcc597966a71db46864d8ab3..2300290ce294882477fdf7df9623afd83e7bcbc0 100644 (file)
@@ -40,7 +40,7 @@
        &board_HW553,
        &board_spw303v,
  #endif
-@@ -1439,6 +1465,7 @@ static struct of_device_id const bcm963x
+@@ -1440,6 +1466,7 @@ static struct of_device_id const bcm963x
        { .compatible = "alcatel,rg100a", .data = &board_96358vw2, },
        { .compatible = "brcm,bcm96358vw", .data = &board_96358vw, },
        { .compatible = "brcm,bcm96358vw2", .data = &board_96358vw2, },
index 8e3a6eb2da3548a5d29d356a96d84ddffb0c7e8b..db9b56e4086fefe04984283bb9b4f06b486a6241 100644 (file)
@@ -45,7 +45,7 @@
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1468,6 +1499,7 @@ static struct of_device_id const bcm963x
+@@ -1469,6 +1500,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,ct-6373", .data = &board_ct6373_1, },
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
index c77b0183686231247c8cbf54d83bf093cba5ca72..d7600372af05af5b561040a80fe9081e379d07cf 100644 (file)
  #ifdef CONFIG_BCM63XX_CPU_6368
        &board_96368mvwg,
        &board_96368mvngr,
-@@ -1510,6 +1582,9 @@ static struct of_device_id const bcm963x
+@@ -1511,6 +1583,9 @@ static struct of_device_id const bcm963x
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
index 0cfe941af5a38d5539b1bbb6e7bdc55d7839dcde..fae52cb9e3ba7018352d4892bc8b86fa97b103b1 100644 (file)
@@ -32,7 +32,7 @@
        &board_DV201AMR,
        &board_96348gw_a,
        &board_rta1025w_16,
-@@ -1556,6 +1574,7 @@ static struct of_device_id const bcm963x
+@@ -1557,6 +1575,7 @@ static struct of_device_id const bcm963x
        { .compatible = "netgear,dg834gtpn", .data = &board_96348gw_10, },
        { .compatible = "netgear,dg834g-v4", .data = &board_96348W3, },
        { .compatible = "sagem,f@st2404", .data = &board_FAST2404, },
index 76b9faf972f5d891c5673bdc9f0ec0b660be73d0..8541a65c65153619a16d8b5bc0e8561c6d5d2ac9 100644 (file)
        &board_spw303v,
        &board_DVAG3810BN,
  #endif
-@@ -1788,6 +1879,9 @@ static struct of_device_id const bcm963x
+@@ -1789,6 +1880,9 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
        { .compatible = "huawei,hg553", .data = &board_HW553, },
index 0db9a2e500a01ed61e1efb928972aff01c14a278..1d70064202fa57c54602a5c9405ab3e4ba0e39d5 100644 (file)
@@ -58,7 +58,7 @@ Signed-off-by: Max Staudt <openwrt.max@enpas.org>
  #endif
  
  #ifdef CONFIG_BCM63XX_CPU_6368
-@@ -1955,6 +1993,7 @@ static struct of_device_id const bcm963x
+@@ -1956,6 +1994,7 @@ static struct of_device_id const bcm963x
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_6362
index 8812aecc1de598471c1d0ce8e87fa5a729ae77d2..ccee0a8ac6a40118aca518fc7a963ab87230993a 100644 (file)
@@ -75,7 +75,7 @@
        &board_963269bhr,
        &board_vw6339gu,
  #endif
-@@ -2137,6 +2198,7 @@ static struct of_device_id const bcm963x
+@@ -2138,6 +2199,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
index 805b9d3896bfd1b7fdc1b90420b88a82b700309c..c30467534da26c275d72add90a595051d647db8f 100644 (file)
@@ -84,7 +84,7 @@
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
        &board_963268bu_p300,
-@@ -2196,6 +2258,7 @@ static struct of_device_id const bcm963x
+@@ -2197,6 +2259,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 0506ea64cf60484466a2a71b01ea19835dc6d8c7..9fce17d907c37c5c566b9a0ef68fc1451aaace3d 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2258,6 +2313,7 @@ static struct of_device_id const bcm963x
+@@ -2259,6 +2314,7 @@ static struct of_device_id const bcm963x
  #ifdef CONFIG_BCM63XX_CPU_6368
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
index 1619ee1a67b5552b95c52db44afa54d200d90627..5c27a05d4858e57c86d56099123dc623a5eb506f 100644 (file)
@@ -69,7 +69,7 @@
        &board_WAP5813n,
  #endif
  #ifdef CONFIG_BCM63XX_CPU_63268
-@@ -2314,6 +2369,7 @@ static struct of_device_id const bcm963x
+@@ -2315,6 +2370,7 @@ static struct of_device_id const bcm963x
        { .compatible = "brcm,bcm96368mvngr", .data = &board_96368mvngr, },
        { .compatible = "brcm,bcm96368mvwg", .data = &board_96368mvwg, },
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
index 480d9fc8c7b86ae344a6f8cf1015a4c2adcdcf96..d1d8cad296379fd5c4ce48bfeccbb5478e0f875d 100644 (file)
@@ -58,7 +58,7 @@
        &board_VR3025u,
        &board_VR3025un,
        &board_WAP5813n,
-@@ -2371,6 +2415,7 @@ static struct of_device_id const bcm963x
+@@ -2372,6 +2416,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index c84b19410453514ddcbdbb25cfecf08dc88c6d01..bd67ed4f315e6ef5095538e599978d9aa772d6e2 100644 (file)
@@ -46,7 +46,7 @@
        &board_HW553,
        &board_HW556_A,
        &board_HW556_B,
-@@ -2392,6 +2424,7 @@ static struct of_device_id const bcm963x
+@@ -2393,6 +2425,7 @@ static struct of_device_id const bcm963x
        { .compatible = "d-link,dsl-274xb-c2", .data = &board_dsl_274xb_rev_c, },
        { .compatible = "d-link,dsl-2650u", .data = &board_96358vw2, },
        { .compatible = "d-link,dva-g3810bn/tl", .data = &board_DVAG3810BN, },
index 82dfe68ce7ebf2877948f70f335df09a9ec443c5..3b9551d03ee8918955dd57591b6cf049abdbdda3 100644 (file)
@@ -57,7 +57,7 @@
        &board_P870HW51A_V2,
        &board_VR3025u,
        &board_VR3025un,
-@@ -2630,6 +2673,7 @@ static struct of_device_id const bcm963x
+@@ -2631,6 +2674,7 @@ static struct of_device_id const bcm963x
        { .compatible = "comtrend,vr-3025u", .data = &board_VR3025u, },
        { .compatible = "comtrend,vr-3025un", .data = &board_VR3025un, },
        { .compatible = "comtrend,wap-5813n", .data = &board_WAP5813n, },
index d8a706cc5de935306084e966677cdbadf28ca997..d9b4a4f4205f3d91b3f5655463e00eafd38013d2 100644 (file)
@@ -41,7 +41,7 @@
        &board_HW520,
        &board_HW553,
        &board_HW556_A,
-@@ -2662,6 +2689,7 @@ static struct of_device_id const bcm963x
+@@ -2663,6 +2690,7 @@ static struct of_device_id const bcm963x
        { .compatible = "sfr,nb4-fxc-r1", .data = &board_nb4_fxc_r1, },
        { .compatible = "t-com,spw303v", .data = &board_spw303v, },
        { .compatible = "telsey,cpva642", .data = &board_CPVA642, },
index 3ca8fe16ff97d423e381f81c1c5f039453b32242..f76ac5c36196086e597a59392dab59142d066d4e 100644 (file)
@@ -15,6 +15,15 @@ define Profile/BTHOMEHUB2A/Description
 endef
 $(eval $(call Profile,BTHOMEHUB2A))
 
+define Profile/BTV2110
+  NAME:=BT Voyager V2110
+  PACKAGES:=kmod-b43 wpad-mini
+endef
+define Profile/BTV2500V/Description
+  Package set optimized for BTV2110.
+endef
+$(eval $(call Profile,BTV2110))
+
 define Profile/BTV2500V
   NAME:=BT Voyager V2500V
   PACKAGES:=kmod-b43 wpad-mini