imagebuilder: store package lists in cache directory
authorJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2015 16:57:03 +0000 (16:57 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Mon, 14 Sep 2015 16:57:03 +0000 (16:57 +0000)
Force opkg to store the downloaded repository indizes into the cache
directory as well, this way the IB can be used in an offline setting
once all required files have been cached.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 46912

target/imagebuilder/files/Makefile

index 479fa0e8500bdc7adf9a4f33fa9d3c83c3f1f211..f612ea9abc25e04e795791aa99563ef228efb3dc 100644 (file)
@@ -53,6 +53,7 @@ help: FORCE
 
 # override variables from rules.mk
 PACKAGE_DIR:=$(TOPDIR)/packages
+LISTS_DIR:=$(subst $(space),/,$(patsubst %,..,$(subst /,$(space),$(TARGET_DIR))))$(DL_DIR)
 OPKG:= \
   IPKG_NO_SCRIPT=1 \
   IPKG_TMP="$(TMP_DIR)/ipkgtmp" \
@@ -65,6 +66,7 @@ OPKG:= \
        --force-overwrite \
        --force-postinstall \
        --cache $(DL_DIR) \
+       --lists-dir $(LISTS_DIR) \
        --offline-root $(TARGET_DIR) \
        --add-dest root:/ \
        --add-arch all:100 \