brcm63xx: image: trim revision code used for --rsa-signature
authorJo-Philipp Wich <jo@mein.io>
Wed, 14 Dec 2016 16:10:52 +0000 (17:10 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 14 Dec 2016 17:39:14 +0000 (18:39 +0100)
The imagetag RSA signature field may not exceed 20 characters, so trim the
Git hash portion from the REVISION variable in order to ensure that the
resulting string fits within this field.

The current revision values may be longer than 20 chars, especially when
building within a dirty tree. In this case, the revision will look like
"r2435+75-b4aa3c8" which, combined with the "LEDE-" prefix, is 21 chars long.

Fixes the following error spotted by the buildbots:

    Error: RSA Signature (rsa_signature,r) too long.
    make[4]: *** [.../lede-brcm63xx-generic-NEUFBOX6-squashfs-cfe.bin] Error 1

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/linux/brcm63xx/image/bcm63xx.mk

index 34d496e928511fcf2010215efed291dd0e690001..ce03f7b700290437ed2e9be54a023bfe441a5502 100644 (file)
@@ -922,7 +922,7 @@ define Device/NEUFBOX4-SER
   DEVICE_DTS := nb4-ser-r0
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+  CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -934,7 +934,7 @@ define Device/NEUFBOX4-FXC
   DEVICE_DTS := nb4-fxc-r1
   CFE_BOARD_ID := 96358VW
   CFE_CHIP_ID := 6358
-  CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+  CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef
@@ -946,7 +946,7 @@ define Device/NEUFBOX6
   DEVICE_DTS := nb6-ser-r0
   CFE_BOARD_ID := NB6-SER-r0
   CFE_CHIP_ID := 6362
-  CFE_EXTRAS += --rsa-signature "LEDE-$(REVISION)"
+  CFE_EXTRAS += --rsa-signature "LEDE-$(firstword $(subst -,$(space),$(REVISION)))"
   DEVICE_PACKAGES := \
     $(B43_PACKAGES) $(USB2_PACKAGES)
 endef