try to load the orion glue automatically
authorImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:36:38 +0000 (09:36 +0000)
committerImre Kaloz <kaloz@openwrt.org>
Tue, 1 Jul 2014 09:36:38 +0000 (09:36 +0000)
Signed-off-by: Imre Kaloz <kaloz@openwrt.org>
SVN-Revision: 41434

package/kernel/linux/modules/usb.mk

index 9aa3e8c7028a6e1ec4cfe451b6ff699014172ffd..96c899a8dd8e27326d025c505175e7b9a422564f 100644 (file)
@@ -397,7 +397,7 @@ ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.8.0)),1)
   ifneq ($(wildcard $(LINUX_DIR)/drivers/usb/host/ehci-orion.ko),)
     FILES+=$(LINUX_DIR)/drivers/usb/host/ehci-orion.ko
   endif
-  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform,1)
+  AUTOLOAD:=$(call AutoLoad,40,ehci-hcd ehci-platform ehci-orion,1)
 else
   FILES:=$(LINUX_DIR)/drivers/usb/host/ehci-hcd.ko
   AUTOLOAD:=$(call AutoLoad,40,ehci-hcd,1)