6relayd: prevent build on AVR32
authorFlorian Fainelli <florian@openwrt.org>
Thu, 27 Jun 2013 15:33:05 +0000 (15:33 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 27 Jun 2013 15:33:05 +0000 (15:33 +0000)
AVR32 misses a bunch of updated syscalls, including timerfd_create()
which is used by 6relayd. Since that requires Linux/libc changes, just
prevent building it for now.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 37040

package/network/ipv6/6relayd/Makefile

index bd1580b48a0e3e07f53469b4cf8a250c22f34c55..f04a96d50c9125c4a6163448485d5b2ebdc52d8d 100644 (file)
@@ -26,7 +26,7 @@ define Package/6relayd
   SECTION:=net
   CATEGORY:=Network
   TITLE:=DHCPv6(-PD)/RA Server & Relay
-  DEPENDS:=+kmod-ipv6
+  DEPENDS:=+kmod-ipv6 @!TARGET_avr32
 endef
 
 define Package/6relayd/description