build: allow simple build system customization with local.mk
authorPetr Štetiar <ynezz@true.cz>
Mon, 7 Jan 2019 00:57:01 +0000 (01:57 +0100)
committerPetr Štetiar <ynezz@true.cz>
Thu, 25 Jul 2019 05:48:02 +0000 (07:48 +0200)
I tend to automate most of the boring and repetitive tasks like firmware
flashing, build config reconfiguration etc., so I always end up adding
`include local.mk` as a last line in my Makefile, where local.mk is
usually symlink to some other place, just to not accidentally delete it
during `git clean`.

Carrying this single uncommited modification along in the development
process is quite PITA, because it's causing problems during Git
workflow, while rebasing etc.

I hope, that I'm not alone using similar workflow, so I believe, that
this modification might be useful for others as well.

Signed-off-by: Petr Štetiar <ynezz@true.cz>
Makefile

index 5301883061589de7c4a7ffbb5e4a8d4c0588f6c6..1ccfd61d680ce11a716e101d3e40f85227b63a23 100644 (file)
--- a/Makefile
+++ b/Makefile
@@ -103,3 +103,5 @@ world: prepare $(target/stamp-compile) $(package/stamp-compile) $(package/stamp-
 .PHONY: clean dirclean prereq prepare world package/symlinks package/symlinks-install package/symlinks-clean
 
 endif
+
+-include local.mk