ramips: rename TP-Link Archer C20 to TP-Link Archer C20 v1
authorMaxim Anisimov <maxim.anisimov.ua@gmail.com>
Sat, 13 Jan 2018 07:16:20 +0000 (10:16 +0300)
committerMathias Kresin <dev@kresin.me>
Mon, 15 Jan 2018 20:45:43 +0000 (21:45 +0100)
This changes device name from "TP-Link Archer C20" to "TP-Link Archer C20 v1"
because of TPLINK released new TP-Link Archer C20 v4. Additionally
migration to the generic board detection has been made.

Signed-off-by: Maxim Anisimov <maxim.anisimov.ua@gmail.com>
target/linux/ramips/base-files/etc/board.d/01_leds
target/linux/ramips/base-files/etc/board.d/02_network
target/linux/ramips/base-files/etc/diag.sh
target/linux/ramips/base-files/lib/ramips.sh
target/linux/ramips/base-files/lib/upgrade/platform.sh
target/linux/ramips/dts/ArcherC20.dts [deleted file]
target/linux/ramips/dts/ArcherC20v1.dts [new file with mode: 0644]
target/linux/ramips/image/mt7620.mk

index 3e26493e545f8e71c96453f2364154cbac55519c..37393eeb27f877862487feaec708501afec7f674 100755 (executable)
@@ -91,12 +91,6 @@ c108)
        ucidef_set_led_netdev "lan" "lan" "$boardname:green:lan" "eth0"
        ucidef_set_led_netdev "modem" "modem" "$boardname:green:modem" "wwan0"
        ;;
-c20)
-       ucidef_set_led_switch "lan" "lan" "$boardname:blue:lan" "switch0" "0x1e"
-       ucidef_set_led_switch "wan" "wan" "$boardname:blue:wan" "switch0" "0x01"
-       set_usb_led "$boardname:blue:usb"
-       ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:blue:wlan2g" "wlan0"
-       ;;
 c20i)
        ucidef_set_led_switch "lan" "lan" "$boardname:blue:lan" "switch0" "0x1e"
        ucidef_set_led_switch "wan" "wan" "$boardname:blue:wan" "switch0" "0x01"
@@ -388,6 +382,12 @@ tl-wr841n-v13)
        ucidef_set_led_switch "lan4" "lan4" "$boardname:green:lan4" "switch0" "0x10"
        ucidef_set_led_switch "wan" "wan" "$boardname:green:wan" "switch0" "0x01"
        ;;
+tplink,c20-v1)
+       ucidef_set_led_switch "lan" "lan" "$boardname:blue:lan" "switch0" "0x1e"
+       ucidef_set_led_switch "wan" "wan" "$boardname:blue:wan" "switch0" "0x01"
+       set_usb_led "$boardname:blue:usb"
+       ucidef_set_led_netdev "wlan2g" "wlan2g" "$boardname:blue:wlan2g" "wlan0"
+       ;;
 tplink,tl-mr3420-v5)
        set_usb_led "$boardname:green:usb"
        set_wifi_led "$boardname:green:wlan"
index 105f5e9e32a80a2b4d9b4c9332c4c13549bebdb8..a90fe96f91fe9a1276d2ea930bd05e78624a219e 100755 (executable)
@@ -190,8 +190,8 @@ ramips_setup_interfaces()
                ucidef_add_switch "switch0" \
                        "1:lan" "2:lan" "3:lan" "4:lan" "0:wan" "6@eth0"
                ;;
-       c20|\
-       c50)
+       c50|\
+       tplink,c20-v1)
                ucidef_add_switch "switch0" \
                        "1:lan:3" "2:lan:4" "3:lan:1" "4:lan:2" "0:wan" "6@eth0"
                ;;
index e1d29152f110295aa8204f3169479a93ab44a891..df9858cb32e84b5f00c2c3bdb44bac77a726773b 100644 (file)
@@ -124,7 +124,6 @@ get_status_led() {
        w502u)
                status_led="$boardname:blue:wps"
                ;;
-       c20|\
        d240|\
        dap-1350|\
        na930|\
@@ -136,6 +135,7 @@ get_status_led() {
        rt-n14u|\
        rt-n15|\
        rt-n56u|\
+       tplink,c20-v1|\
        wl-330n|\
        wl-330n3g|\
        wli-tx4-ag300n|\
index e85b29361057c0f3acdc061bfb11b9b6b283d93b..3ba6d0f0f5d231a3e0664d998686528195593ebe 100755 (executable)
@@ -85,9 +85,6 @@ ramips_board_detect() {
        *"C108")
                name="c108"
                ;;
-       *"C20")
-               name="c20"
-               ;;
        *"C20i")
                name="c20i"
                ;;
index e2ab3a643e5ed6e9edb3ab523fe58210327d5a77..71ad0c1b831e3f5d502ebe3fa7487a309c8708fb 100755 (executable)
@@ -237,10 +237,10 @@ platform_check_image() {
                }
                return 0
                ;;
-       c20|\
        c20i|\
        c50|\
        mr200|\
+       tplink,c20-v1|\
        tplink,tl-mr3420-v5|\
        tl-wr840n-v4|\
        tl-wr840n-v5|\
diff --git a/target/linux/ramips/dts/ArcherC20.dts b/target/linux/ramips/dts/ArcherC20.dts
deleted file mode 100644 (file)
index f0281c3..0000000
+++ /dev/null
@@ -1,187 +0,0 @@
-/dts-v1/;
-
-#include "mt7620a.dtsi"
-
-#include <dt-bindings/input/input.h>
-#include <dt-bindings/gpio/gpio.h>
-
-/ {
-       compatible = "tplink,c20", "ralink,mt7620a-soc";
-       model = "TP-Link Archer C20";
-
-       chosen {
-               bootargs = "console=ttyS0,115200";
-       };
-
-       gpio-leds {
-               compatible = "gpio-leds";
-
-               lan {
-                       label = "c20:blue:lan";
-                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
-               };
-
-               power {
-                       label = "c20:blue:power";
-                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
-                       default-state = "keep";
-               };
-
-               usb {
-                       label = "c20:blue:usb";
-                       gpios = <&gpio2 4 GPIO_ACTIVE_LOW>;
-               };
-
-               wan {
-                       label = "c20:blue:wan";
-                       gpios = <&gpio0 11 GPIO_ACTIVE_HIGH>;
-               };
-
-               wan_orange {
-                       label = "c20:orange:wan";
-                       gpios = <&gpio0 9 GPIO_ACTIVE_HIGH>;
-               };
-
-               wlan5g {
-                       label = "c20:blue:wlan5g";
-                       gpios = <&gpio0 17 GPIO_ACTIVE_LOW>;
-               };
-
-               wlan2g {
-                       label = "c20:blue:wlan2g";
-                       gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
-               };
-
-               wps {
-                       label = "c20:blue:wps";
-                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
-               };
-       };
-
-       gpio-keys-polled {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <20>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RESTART>;
-               };
-
-               rfkill {
-                       label = "rfkill";
-                       gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
-                       linux,code = <KEY_RFKILL>;
-               };      };
-};
-
-&gpio1 {
-       status = "okay";
-};
-
-&gpio2 {
-       status = "okay";
-};
-
-&gpio3 {
-       status = "okay";
-};
-
-&spi0 {
-       status = "okay";
-
-       m25p80@0 {
-               #address-cells = <1>;
-               #size-cells = <1>;
-               compatible = "jedec,spi-nor";
-               reg = <0>;
-               spi-max-frequency = <10000000>;
-
-               partition@0 {
-                       label = "u-boot";
-                       reg = <0x0 0x20000>;
-                       read-only;
-               };
-
-               partition@20000 {
-                       label = "firmware";
-                       reg = <0x20000 0x7a0000>;
-               };
-
-               partition@7c0000 {
-                       label = "config";
-                       reg = <0x7c0000 0x10000>;
-                       read-only;
-               };
-
-               rom: partition@7d0000 {
-                       label = "rom";
-                       reg = <0x7d0000 0x10000>;
-                       read-only;
-               };
-
-               partition@7e0000 {
-                       label = "romfile";
-                       reg = <0x7e0000 0x10000>;
-                       read-only;
-               };
-
-               radio: partition@7f0000 {
-                       label = "radio";
-                       reg = <0x7f0000 0x10000>;
-                       read-only;
-               };
-       };
-};
-
-&pinctrl {
-       state_default: pinctrl0 {
-               gpio {
-                       ralink,group = "i2c", "uartf", "wled", "ephy", "spi refclk", "wdt";
-                       ralink,function = "gpio";
-               };
-       };
-};
-
-&ethernet {
-               pinctrl-names = "default";
-               mtd-mac-address = <&rom 0xf100>;
-               mediatek,portmap = "wllll";
-       };
-
-&ehci {
-       status = "okay";
-};
-
-&ohci {
-       status = "okay";
-};
-
-&gsw {
-       mediatek,port4 = "ephy";
-};
-
-&wmac {
-       ralink,mtd-eeprom = <&radio 0>;
-       mtd-mac-address = <&rom 0xf100>;
-       mtd-mac-address-increment = <(-2)>;
-       pinctrl-names = "default";
-       pinctrl-0 = <&pa_pins>;
-};
-
-&pcie {
-       status = "okay";
-
-       pcie-bridge {
-               mt76@0,0 {
-                       reg = <0x0000 0 0 0 0>;
-                       device_type = "pci";
-                       mediatek,mtd-eeprom = <&radio 32768>;
-                       ieee80211-freq-limit = <5000000 6000000>;
-                       mtd-mac-address = <&rom 0xf100>;
-                       mtd-mac-address-increment = <(-1)>;
-               };
-       };
-};
diff --git a/target/linux/ramips/dts/ArcherC20v1.dts b/target/linux/ramips/dts/ArcherC20v1.dts
new file mode 100644 (file)
index 0000000..9d8a2b5
--- /dev/null
@@ -0,0 +1,188 @@
+/dts-v1/;
+
+#include "mt7620a.dtsi"
+
+#include <dt-bindings/input/input.h>
+#include <dt-bindings/gpio/gpio.h>
+
+/ {
+       compatible = "tplink,c20-v1", "ralink,mt7620a-soc";
+       model = "TP-Link Archer C20 v1";
+
+       chosen {
+               bootargs = "console=ttyS0,115200";
+       };
+
+       gpio-leds {
+               compatible = "gpio-leds";
+
+               lan {
+                       label = "c20-v1:blue:lan";
+                       gpios = <&gpio0 1 GPIO_ACTIVE_LOW>;
+               };
+
+               power {
+                       label = "c20-v1:blue:power";
+                       gpios = <&gpio0 7 GPIO_ACTIVE_LOW>;
+                       default-state = "keep";
+               };
+
+               usb {
+                       label = "c20-v1:blue:usb";
+                       gpios = <&gpio2 4 GPIO_ACTIVE_LOW>;
+               };
+
+               wan {
+                       label = "c20-v1:blue:wan";
+                       gpios = <&gpio0 11 GPIO_ACTIVE_HIGH>;
+               };
+
+               wan_orange {
+                       label = "c20-v1:orange:wan";
+                       gpios = <&gpio0 9 GPIO_ACTIVE_HIGH>;
+               };
+
+               wlan5g {
+                       label = "c20-v1:blue:wlan5g";
+                       gpios = <&gpio0 17 GPIO_ACTIVE_LOW>;
+               };
+
+               wlan2g {
+                       label = "c20-v1:blue:wlan2g";
+                       gpios = <&gpio3 0 GPIO_ACTIVE_LOW>;
+               };
+
+               wps {
+                       label = "c20-v1:blue:wps";
+                       gpios = <&gpio1 15 GPIO_ACTIVE_LOW>;
+               };
+       };
+
+       gpio-keys-polled {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <20>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio0 13 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RESTART>;
+               };
+
+               rfkill {
+                       label = "rfkill";
+                       gpios = <&gpio0 2 GPIO_ACTIVE_LOW>;
+                       linux,code = <KEY_RFKILL>;
+               };
+       };
+};
+
+&gpio1 {
+       status = "okay";
+};
+
+&gpio2 {
+       status = "okay";
+};
+
+&gpio3 {
+       status = "okay";
+};
+
+&spi0 {
+       status = "okay";
+
+       m25p80@0 {
+               #address-cells = <1>;
+               #size-cells = <1>;
+               compatible = "jedec,spi-nor";
+               reg = <0>;
+               spi-max-frequency = <10000000>;
+
+               partition@0 {
+                       label = "u-boot";
+                       reg = <0x0 0x20000>;
+                       read-only;
+               };
+
+               partition@20000 {
+                       label = "firmware";
+                       reg = <0x20000 0x7a0000>;
+               };
+
+               partition@7c0000 {
+                       label = "config";
+                       reg = <0x7c0000 0x10000>;
+                       read-only;
+               };
+
+               rom: partition@7d0000 {
+                       label = "rom";
+                       reg = <0x7d0000 0x10000>;
+                       read-only;
+               };
+
+               partition@7e0000 {
+                       label = "romfile";
+                       reg = <0x7e0000 0x10000>;
+                       read-only;
+               };
+
+               radio: partition@7f0000 {
+                       label = "radio";
+                       reg = <0x7f0000 0x10000>;
+                       read-only;
+               };
+       };
+};
+
+&pinctrl {
+       state_default: pinctrl0 {
+               gpio {
+                       ralink,group = "i2c", "uartf", "wled", "ephy", "spi refclk", "wdt";
+                       ralink,function = "gpio";
+               };
+       };
+};
+
+&ethernet {
+               pinctrl-names = "default";
+               mtd-mac-address = <&rom 0xf100>;
+               mediatek,portmap = "wllll";
+       };
+
+&ehci {
+       status = "okay";
+};
+
+&ohci {
+       status = "okay";
+};
+
+&gsw {
+       mediatek,port4 = "ephy";
+};
+
+&wmac {
+       ralink,mtd-eeprom = <&radio 0>;
+       mtd-mac-address = <&rom 0xf100>;
+       mtd-mac-address-increment = <(-2)>;
+       pinctrl-names = "default";
+       pinctrl-0 = <&pa_pins>;
+};
+
+&pcie {
+       status = "okay";
+
+       pcie-bridge {
+               mt76@0,0 {
+                       reg = <0x0000 0 0 0 0>;
+                       device_type = "pci";
+                       mediatek,mtd-eeprom = <&radio 0x8000>;
+                       ieee80211-freq-limit = <5000000 6000000>;
+                       mtd-mac-address = <&rom 0xf100>;
+                       mtd-mac-address-increment = <(-1)>;
+               };
+       };
+};
index 6f9aa1aa6d4a85e803b3228d6014e732c85af054..d4c4e719b7489ef3813d30a9ff8cba30cf670bb1 100644 (file)
@@ -45,20 +45,6 @@ define Device/Archer
   IMAGE/sysupgrade.bin := tplink-v2-image -s -e | append-metadata
 endef
 
-define Device/ArcherC20
-  $(Device/Archer)
-  DTS := ArcherC20
-  SUPPORTED_DEVICES := c20
-  TPLINK_FLASHLAYOUT := 8Mmtk
-  TPLINK_HWID := 0xc2000001
-  TPLINK_HWREV := 0x44
-  TPLINK_HWREVADD := 0x1
-  IMAGES += factory.bin
-  DEVICE_TITLE := TP-Link ArcherC20
-  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
-endef
-TARGET_DEVICES += ArcherC20
-
 define Device/ArcherC20i
   $(Device/Archer)
   DTS := ArcherC20i
@@ -433,6 +419,20 @@ define Device/tiny-ac
 endef
 TARGET_DEVICES += tiny-ac
 
+define Device/tplink_c20-v1
+  $(Device/Archer)
+  DTS := ArcherC20v1
+  SUPPORTED_DEVICES := c20v1
+  TPLINK_FLASHLAYOUT := 8Mmtk
+  TPLINK_HWID := 0xc2000001
+  TPLINK_HWREV := 0x44
+  TPLINK_HWREVADD := 0x1
+  IMAGES += factory.bin
+  DEVICE_TITLE := TP-Link ArcherC20 v1
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-ledtrig-usbport
+endef
+TARGET_DEVICES += tplink_c20-v1
+
 define Device/vonets_var11n-300
   DTS := VAR11N-300
   IMAGE_SIZE := $(ralink_default_fw_size_4M)