kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
[openwrt/staging/dedeckeh.git] / target / linux / atheros / Makefile
index 46adcf3759b41bb2dab4680c24b5857c5a03338e..1b52909476d5d534f8157e0b86d2e270e3bbc961 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2006-2008 OpenWrt.org
+# Copyright (C) 2006-2013 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -9,13 +9,13 @@ include $(TOPDIR)/rules.mk
 ARCH:=mips
 BOARD:=atheros
 BOARDNAME:=Atheros AR231x/AR5312
-FEATURES:=squashfs jffs2
+FEATURES:=squashfs
 
-LINUX_VERSION:=2.6.32.27
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 
-DEFAULT_PACKAGES += wpad-mini kmod-madwifi gpioctl swconfig
+DEFAULT_PACKAGES += wpad-mini kmod-ath5k swconfig kmod-gpio-button-hotplug
 
 define Target/Description
        Build firmware images for Atheros SoC boards