kernel: update to 3.10.49 Signed-off-by: John Crispin <blogic@openwrt.org>
[openwrt/staging/dedeckeh.git] / target / linux / brcm2708 / Makefile
index 5fc4e6b94a0b539113c02dd9ab29bdf7e39a3246..afb62016e1385a89bc36d496c6be85330b9a0476 100644 (file)
@@ -12,8 +12,10 @@ BOARD:=brcm2708
 BOARDNAME:=Broadcom BCM2708/BCM2835
 FEATURES:=ext4 audio usb usbgadget display gpio
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
+CPU_TYPE:=arm1176jzf-s
+CPU_SUBTYPE:=vfp
 
-LINUX_VERSION:=3.10.4
+LINUX_VERSION:=3.10.49
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += brcm2708-gpu-fw kmod-usb-hid kmod-sound-core kmod-sound-arm-bcm2835
@@ -23,6 +25,6 @@ define Target/Description
        Currently produces SD Card image for Raspberry Pi.
 endef
 
-CFLAGS:=-pipe -march=armv6 -mtune=arm1176jzf-s -mfpu=vfp -mfloat-abi=softfp -marm
+KERNELNAME="Image"
 
 $(eval $(call BuildTarget))