tools/sdimage: Fix build with host Linux headers < 3.18
authorHauke Mehrtens <hauke@hauke-m.de>
Sun, 16 Dec 2018 12:57:01 +0000 (13:57 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Sun, 16 Dec 2018 13:03:35 +0000 (14:03 +0100)
The ufb tool needs the host UAPI Linux headers from kernel 3.18
or later, remove it for now as it is not used anyway.

Fixes: 4bf5c4395b3 ("tools/sdimage: update to latest git version")
Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
tools/sdimage/patches/100-deactivate-ufb.patch [new file with mode: 0644]

diff --git a/tools/sdimage/patches/100-deactivate-ufb.patch b/tools/sdimage/patches/100-deactivate-ufb.patch
new file mode 100644 (file)
index 0000000..2bf6ad2
--- /dev/null
@@ -0,0 +1,13 @@
+Deactivate ufb, this needs the UAPI Linux kernel headers from >= 3.18, 
+this tools is currently not used, so just remove it for now.
+
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,6 @@
+ CC ?= $(CROSS_COMPILE)gcc
+ BINDIR ?= /usr/sbin
+-PROGRAMS = uuc sdimage ufb
++PROGRAMS = uuc sdimage
+ LIBS ?= -lpthread
+ all: $(PROGRAMS)