kernel: make kmod-ipt-filter available on brcm-2.4, kernel 2.4 provides a textsearch...
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 1 May 2009 22:59:07 +0000 (22:59 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 1 May 2009 22:59:07 +0000 (22:59 +0000)
SVN-Revision: 15549

package/kernel/modules/netfilter.mk

index 6226c7e246cb14ecfff59da82298cc1eb545fb1d..45ae41f926c695777ab05869ad768ca86d7a9990 100644 (file)
@@ -78,7 +78,7 @@ define KernelPackage/ipt-filter
   KCONFIG:=$(KCONFIG_IPT_FILTER)
   FILES:=$(foreach mod,$(IPT_FILTER-m),$(LINUX_DIR)/net/$(mod).$(LINUX_KMOD_SUFFIX))
   AUTOLOAD:=$(call AutoLoad,45,$(notdir $(IPT_FILTER-m)))
-  DEPENDS:= kmod-ipt-core +kmod-textsearch
+  DEPENDS:= kmod-ipt-core @LINUX_2_4||+kmod-textsearch
 endef
 
 define KernelPackage/ipt-filter/description