kernel: Enable CONFIG_SPI_SPIDEV when selecting kmod-spidev
authorFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:50:34 +0000 (04:50 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 20 May 2014 04:50:34 +0000 (04:50 +0000)
Without this patch /dev/spidev*.* only appears if CONFIG_SPI_SPIDEV is manually
selected and set to "y" from the kernel config.

Signed-off-by: Álvaro Fernández Rojas <noltari@gmail.com>
Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 40784

package/kernel/linux/modules/spi.mk

index 1c2a789fedc153aedfb81daab93f5c76a4a01929..c54dcc2d2ac0a0cb024df5fb0bd3f2a2c96733c6 100644 (file)
@@ -77,7 +77,7 @@ $(eval $(call KernelPackage,spi-gpio))
 define KernelPackage/spi-dev
   SUBMENU:=$(SPI_MENU)
   TITLE:=User mode SPI device driver
-  KCONFIG:=CONFIG_SPI_SPIDEV \
+  KCONFIG:=CONFIG_SPI_SPIDEV=y \
           CONFIG_SPI=y \
           CONFIG_SPI_MASTER=y
   FILES:=$(LINUX_DIR)/drivers/spi/spidev.ko