lantiq-vdsl-fw: update to provide recent vectoring firmware
authorDaniel Golle <daniel@makrotopia.org>
Fri, 15 Jun 2018 10:21:03 +0000 (12:21 +0200)
committerDaniel Golle <daniel@makrotopia.org>
Fri, 15 Jun 2018 10:45:37 +0000 (12:45 +0200)
Recent Speedport firmware downloads only work over HTTPS, so the user
either needs to provide the already downloaded file or install
ustream-ssl-* as well as ca-certificates or ca-bundle.

So to get VDSL2 with vectoring on xRX200, simply run
vdsl_fw_install.sh
on the target and either provide the downloaded file as instructed or
make sure the device is connected to the Internet and can download that
HTTPS url itself.

Signed-off-by: Daniel Golle <daniel@makrotopia.org>
package/kernel/lantiq/ltq-vdsl-fw/Makefile
package/kernel/lantiq/ltq-vdsl-fw/src/vdsl_fw_install.sh
package/kernel/lantiq/ltq-vdsl-fw/src/w921v_fw_cutter.c
target/linux/lantiq/xrx200/target.mk

index 64040677077eb75f552e491c27c16d7d097c5e1d..f021aa3dcfef45f528cd87b0b8adf6f4dc9297bd 100644 (file)
@@ -9,12 +9,12 @@ PKG_NAME:=ltq-vdsl-fw
 PKG_VERSION:=1
 PKG_RELEASE:=1
 
-PKG_MAINTAINER:=John Crispin <blogic@openwrt.org>
+PKG_MAINTAINER:=Daniel Golle <daniel@makrotopia.org>
 
 include $(INCLUDE_DIR)/package.mk
 
-define Package/ltq-vdsl-vr9-fw-installer
-  TITLE:=Firmware installer
+define Package/ltq-vdsl-vr9-vectoring-fw-installer
+  TITLE:=VDSL2 Vectoring Firmware installer
   SECTION:=net
   CATEGORY:=Network
   DEPENDS:=@TARGET_lantiq_xrx200 +kmod-ltq-vdsl-vr9
@@ -37,4 +37,4 @@ define Package/ltq-vdsl-vr9-fw-installer/install
        $(CP) $(PKG_BUILD_DIR)/w921v_fw_cutter $(PKG_BUILD_DIR)/vdsl_fw_install.sh $(1)/sbin/
 endef
 
-$(eval $(call BuildPackage,ltq-vdsl-vr9-fw-installer))
+$(eval $(call BuildPackage,ltq-vdsl-vr9-vectoring-fw-installer))
index 4572abc0607078dccffc5d8e947383dfb60cebd0..fa99ed2777510e88de7a0a00eba46debacb99d6d 100755 (executable)
@@ -1,13 +1,13 @@
 #!/bin/sh
 . /lib/functions.sh
 
-FW="/tmp/Firmware_Speedport_W921V_1.21.000.bin"
-URL="http://hilfe.telekom.de/dlp/eki/downloads/Speedport/Speedport%20W%20921V/Firmware_Speedport_W921V_1.21.000.bin"
+FW="/tmp/firmware-speedport-w921v-1.44.000.bin"
+URL="https://www.telekom.de/hilfe/downloads/firmware-speedport-w921v-1.44.000.bin"
 FW_TAPI="vr9_tapi_fw.bin"
 FW_DSL="vr9_dsl_fw_annex_b.bin"
-MD5_FW="0a099d08dbf091c74d685b532cbb1390"
-MD5_TAPI="06b6ab3481b8d3eb7e8bf6131f7f6b7f"
-MD5_DSL="59dd9dc81195c6854433c691b163f757"
+MD5_FW="cefbeb7073e02e0fa4ddb6b31ecb3d1e"
+MD5_TAPI="57f2d07f59e11250ce1219bad99c1eda"
+MD5_DSL="655442e31deaa42c9c68944869361ec0"
 
 [ -f /lib/firmware/vdsl.bin ] && exit 0
 
@@ -19,6 +19,7 @@ MD5_DSL="59dd9dc81195c6854433c691b163f757"
        echo ""
        [ "$R" = "y" ] || {
                echo "Please manually download the firmware from ${URL} and copy the file to ${FW}"
+               echo "See also https://xdarklight.github.io/lantiq-xdsl-firmware-info/ for alternatives"
                exit 1
        }
        echo "Download w921v Firmware"
index fcd0106e4595865a1c4b44536ac768403d73aa06..6082bdadb6e3812b17f9add7836fb196763b1e16 100644 (file)
@@ -26,7 +26,7 @@
 
 #include "LzmaWrapper.h"
 
-#define FW_NAME                "/tmp/Firmware_Speedport_W921V_1.21.000.bin"
+#define FW_NAME                "/tmp/firmware-speedport-w921v-1.44.000.bin"
 
 #define MAGIC          0x50
 #define MAGIC_SZ       0x3FFC00
@@ -78,7 +78,7 @@ int main(int argc, char **argv)
 
        if (stat(FW_NAME, &s) != 0) {
                printf("Failed to find %s\n", FW_NAME);
-               printf("Ask Google or try http://hilfe.telekom.de/dlp/eki/downloads/Speedport/Speedport%20W%20921V/Firmware_Speedport_W921V_1.21.000.bin\n");
+               printf("Ask Google or try https://www.telekom.de/hilfe/downloads/firmware-speedport-w921v-1.44.000.bin\n");
                return -1;
        }
 
index 0157dee4fe550a6dd84eb0db314ce5b4ba5d609b..4f682bf4866fed22184d5cb11b6e7ab3470990f9 100644 (file)
@@ -6,7 +6,7 @@ CPU_TYPE:=24kc
 
 DEFAULT_PACKAGES+=kmod-leds-gpio \
        kmod-gpio-button-hotplug \
-       ltq-vdsl-vr9-fw-installer \
+       ltq-vdsl-vr9-vectoring-fw-installer \
        kmod-ltq-vdsl-vr9-mei \
        kmod-ltq-vdsl-vr9 \
        kmod-ltq-atm-vr9 \