* fixes brnboot image generation
authorJohn Crispin <john@openwrt.org>
Mon, 26 Sep 2011 09:00:11 +0000 (09:00 +0000)
committerJohn Crispin <john@openwrt.org>
Mon, 26 Sep 2011 09:00:11 +0000 (09:00 +0000)
SVN-Revision: 28307

package/uboot-lantiq/Makefile

index 015efcfe60153342aad43c40f186b4a9a144d4db..44a0eec8aa7d7782a5ad51e0c53e31e893fa6942 100644 (file)
@@ -119,15 +119,15 @@ endef
 
 define Package/uboot-lantiq-$(BUILD_VARIANT)/install
        mkdir -p $(1)
-ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)
+ifneq ($(findstring flash,$(BUILD_VARIANT)),)
        dd \
-               if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
-               of=$(1)/u-boot.bin \
+               if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
+               of=$(1)/u-boot-bootstrap.bin \
                bs=64k conv=sync
 else
        dd \
-               if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot-bootstrap.bin \
-               of=$(1)/u-boot-bootstrap.bin \
+               if=$(PKG_BUILD_DIR)/$(BUILD_VARIANT)/u-boot.bin \
+               of=$(1)/u-boot.bin \
                bs=64k conv=sync
 endif
 ifneq ($(findstring ramboot,$(BUILD_VARIANT)),)