Add kernel module package for SLIP
authorJohn Crispin <john@openwrt.org>
Tue, 14 Feb 2012 19:07:13 +0000 (19:07 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 14 Feb 2012 19:07:13 +0000 (19:07 +0000)
This patch adds support for a kernel module package for SLIP. We needed it forusing tunslip6 from Contiki OS for 6LoWPAN communications.

Signed-off-by: Markus Becker <mab@comnets.uni-bremen.de>
SVN-Revision: 30538

package/kernel/modules/netsupport.mk

index 93607302a2bcb0db61652a526a95d83012c4229f..bac681b75c3391ab68ee256d3dd2897a5680f3da 100644 (file)
@@ -829,3 +829,28 @@ endef
 
 $(eval $(call KernelPackage,netem))
 
+define KernelPackage/slip
+  SUBMENU:=$(NETWORK_SUPPORT_MENU)
+  TITLE:=SLIP modules
+  KCONFIG:= \
+       CONFIG_SLIP \
+       CONFIG_SLIP_COMPRESSED=y \
+       CONFIG_SLIP_SMART=y \
+       CONFIG_SLIP_MODE_SLIP6=y
+
+  ifeq ($(strip $(call CompareKernelPatchVer,$(KERNEL_PATCHVER),ge,3.2)),1)
+    FILES:= \
+       $(LINUX_DIR)/drivers/net/slip/slip.ko
+  else
+    FILES:= \
+       $(LINUX_DIR)/drivers/net/slip.ko
+  endif
+  AUTOLOAD:=$(call AutoLoad,30,slip)
+endef
+
+define KernelPackage/slip/description
+ Kernel modules for SLIP support
+endef
+
+$(eval $(call KernelPackage,slip))
+