x86: Fix CONFIG_X86_GRUB_SERIAL=""
authorFelix Fietkau <nbd@openwrt.org>
Sat, 10 Aug 2013 18:35:29 +0000 (18:35 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 10 Aug 2013 18:35:29 +0000 (18:35 +0000)
With

    .config:CONFIG_X86_GRUB_SERIAL=""

which (AFAICT) is the way to tell GRUB not to use a serial console, in

    target/linux/x86/image/Makefile:ifneq ($(CONFIG_X86_GRUB_SERIAL),)

$(CONFIG_X86_GRUB_SERIAL) expands to `""' (a literal double double-quote),
making the condition unconditionally false.

This patch fixes the situation by passing CONFIG_X86_GRUB_SERIAL through
qstrip before testing.

Signed-off-by: Tamas TEVESZ <ice@extreme.hu>
SVN-Revision: 37749

target/linux/x86/image/Makefile

index 039d70ab82a207efb6a95f7e24f9c7d897fdf6cb..d3ada9fad268667908ef3a899188d7de91e438c1 100644 (file)
@@ -28,8 +28,10 @@ ifneq ($(CONFIG_X86_GRUB_CONSOLE),)
   GRUB_TERMINALS += console
 endif
 
-ifneq ($(CONFIG_X86_GRUB_SERIAL),)
-  GRUB_CONSOLE_CMDLINE += console=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL)),$(CONFIG_X86_GRUB_BAUDRATE)n8
+GRUB_SERIAL:=$(call qstrip,$(CONFIG_X86_GRUB_SERIAL))
+
+ifneq ($(GRUB_SERIAL),)
+  GRUB_CONSOLE_CMDLINE += console=$(GRUB_SERIAL),$(CONFIG_X86_GRUB_BAUDRATE)n8
   GRUB_SERIAL_CONFIG := serial --unit=0 --speed=$(CONFIG_X86_GRUB_BAUDRATE) --word=8 --parity=no --stop=1
   GRUB_TERMINALS += serial
 endif