dnsmasq: fix dnsmasq startup issue
authorHans Dedecker <dedeckeh@gmail.com>
Wed, 20 Jun 2018 11:21:28 +0000 (13:21 +0200)
committerHans Dedecker <dedeckeh@gmail.com>
Wed, 20 Jun 2018 12:07:19 +0000 (14:07 +0200)
Commit ecd954d530 installs specific interface triggers which rewrites the dnsmasq config
file and restarts dnsmasq if the network interface becomes active for which a trigger
has been installed.
In case no dhcp sections are specified or ignore is set to 1 dnsmasq will not be started
at startup which breaks DNS resolving.
Fix this by ditching the BOOT check in start_service and always start dnsmasq at startup.

Signed-off-by: Hans Dedecker <dedeckeh@gmail.com>
package/network/services/dnsmasq/Makefile
package/network/services/dnsmasq/files/dnsmasq.init

index bb68a67296f3939dec1fa052cc1b945c5a00cd2e..f26f819a3446a50c0d75af0d8cb3138484f3315e 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=dnsmasq
 PKG_VERSION:=2.80test2
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
 PKG_SOURCE_URL:=http://thekelleys.org.uk/dnsmasq/test-releases
index 4906df9ce432781b930a735cd3ad4cad7748c0a8..bb8d07ff354ec5444056b2e645302272ce0fbf8c 100644 (file)
@@ -1061,18 +1061,10 @@ service_triggers()
        config_foreach add_interface_trigger dhcp
 }
 
-boot()
-{
-       BOOT=1
-       start "$@"
-}
-
 start_service() {
        local instance="$1"
        local instance_found=0
 
-       [ -n "$BOOT" ] && return
-
        . /lib/functions/network.sh
 
        config_cb() {