add kmod-fs-configfs to replace kernel bloat added by selecting kmod-mmc-over-gpio
authorFelix Fietkau <nbd@openwrt.org>
Thu, 3 Jan 2013 18:04:04 +0000 (18:04 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 3 Jan 2013 18:04:04 +0000 (18:04 +0000)
SVN-Revision: 34998

package/kernel/modules/fs.mk
package/system/mmc_over_gpio/Makefile

index c4561ef7eecb7efa1efb59a88c8c2960b2642ff0..fc4c7567932e3ed5630e0b1204b63fb07fbba39d 100644 (file)
@@ -69,6 +69,22 @@ endef
 $(eval $(call KernelPackage,fs-cifs))
 
 
+define KernelPackage/fs-configfs
+  SUBMENU:=$(FS_MENU)
+  TITLE:=Configuration filesystem support
+  KCONFIG:= \
+       CONFIG_CONFIGFS_FS
+  FILES:=$(LINUX_DIR)/fs/configfs/configfs.ko
+  AUTOLOAD:=$(call AutoLoad,30,configfs)
+endef
+
+define KernelPackage/fs-configfs/description
+ Kernel module for configfs support
+endef
+
+$(eval $(call KernelPackage,fs-configfs))
+
+
 define KernelPackage/fs-exportfs
   SUBMENU:=$(FS_MENU)
   TITLE:=exportfs kernel server support
index 03096ad033fae7713644a7a41bde224a96230186..8525887dd2c4fbc1ded604dfcfb73bd36b33c0ed 100644 (file)
@@ -15,9 +15,8 @@ include $(INCLUDE_DIR)/package.mk
 
 define KernelPackage/mmc-over-gpio
   SUBMENU:=Other modules
-  DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio-old
-  KCONFIG:=CONFIG_GPIOMMC \
-       CONFIG_CONFIGFS_FS=y
+  DEPENDS:=@GPIO_SUPPORT +kmod-mmc-spi +kmod-spi-gpio-old +kmod-fs-configfs
+  KCONFIG:=CONFIG_GPIOMMC
   TITLE:=MMC/SD card over GPIO support
   FILES:=$(LINUX_DIR)/drivers/mmc/host/gpiommc.ko
   AUTOLOAD:=$(call AutoLoad,93,gpiommc)