dropbear: add ssh-askpass support in configuration
authorKonstantin Demin <rockdrilla@gmail.com>
Wed, 25 Nov 2020 03:14:30 +0000 (06:14 +0300)
committerPetr Štetiar <ynezz@true.cz>
Fri, 11 Dec 2020 12:48:24 +0000 (13:48 +0100)
binary size cost is much less than 1k.

tested on ath79/generic:
  bin: 215128 -> 215132 (+4b)
  ipk: 111183 -> 111494 (+311b)

Signed-off-by: Konstantin Demin <rockdrilla@gmail.com>
package/network/services/dropbear/Config.in
package/network/services/dropbear/Makefile

index 6aa5a7e4e1b9552aef6d1c4aea518ecb415b6e46..15000eff53e4f8bc388fdcaa1c252b78429c662c 100644 (file)
@@ -99,4 +99,14 @@ config DROPBEAR_SCP
        bool "Build dropbear with scp"
        default y
 
+config DROPBEAR_ASKPASS
+       bool "Enable askpass helper support"
+       default n
+       depends on DROPBEAR_DBCLIENT
+       help
+               This enables support for ssh-askpass helper in dropbear client
+               in order to authenticate on remote hosts.
+
+               Increases binary size by about 0.1 kB (MIPS).
+
 endmenu
index 5021c2aee16620ec4339b23184934952efcebad9..af346f44acd7fadf93dc904b3350083a38c6a64c 100644 (file)
@@ -32,7 +32,7 @@ PKG_CONFIG_DEPENDS:= \
        CONFIG_DROPBEAR_CURVE25519 CONFIG_DROPBEAR_ZLIB \
        CONFIG_DROPBEAR_ED25519 CONFIG_DROPBEAR_CHACHA20POLY1305 \
        CONFIG_DROPBEAR_UTMP CONFIG_DROPBEAR_PUTUTLINE \
-       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP
+       CONFIG_DROPBEAR_DBCLIENT CONFIG_DROPBEAR_SCP CONFIG_DROPBEAR_ASKPASS
 
 include $(INCLUDE_DIR)/package.mk
 
@@ -136,6 +136,7 @@ DB_OPT_CONFIG = \
        DROPBEAR_ECDH|CONFIG_DROPBEAR_ECC|1|0 \
        !!DROPBEAR_ECC_384|CONFIG_DROPBEAR_ECC_FULL|1|0 \
        !!DROPBEAR_ECC_521|CONFIG_DROPBEAR_ECC_FULL|1|0 \
+       DROPBEAR_CLI_ASKPASS_HELPER|CONFIG_DROPBEAR_ASKPASS|1|0 \
 
 
 TARGET_CFLAGS += -DARGTYPE=3 -ffunction-sections -fdata-sections -flto