kernel: update linux 3.2 to 3.2.16
authorJonas Gorski <jogo@openwrt.org>
Tue, 24 Apr 2012 09:25:35 +0000 (09:25 +0000)
committerJonas Gorski <jogo@openwrt.org>
Tue, 24 Apr 2012 09:25:35 +0000 (09:25 +0000)
SVN-Revision: 31459

12 files changed:
include/kernel-version.mk
target/linux/au1000/Makefile
target/linux/brcm47xx/Makefile
target/linux/cobalt/Makefile
target/linux/ep93xx/Makefile
target/linux/generic/patches-3.2/811-pci_disable_usb_common_quirks.patch
target/linux/lantiq/Makefile
target/linux/omap4/Makefile
target/linux/ppc44x/Makefile
target/linux/x86/alix2/target.mk
target/linux/x86/net5501/target.mk
target/linux/xburst/Makefile

index 3440f4458da8c091259118b6d5b1a0d39d19c88e..1dd70f6c5d0bdace7e4faeb5f49116f060887489 100644 (file)
@@ -35,8 +35,8 @@ endif
 ifeq ($(LINUX_VERSION),3.1.10)
   LINUX_KERNEL_MD5SUM:=3649bdaa50ffd9114cc16486ec54d83a
 endif
-ifeq ($(LINUX_VERSION),3.2.15)
-  LINUX_KERNEL_MD5SUM:=15174563c4ccfc17953831611bee4002
+ifeq ($(LINUX_VERSION),3.2.16)
+  LINUX_KERNEL_MD5SUM:=246e6bd28ea44c90ec66c7f8b56e4803
 endif
 ifeq ($(LINUX_VERSION),3.3.2)
   LINUX_KERNEL_MD5SUM:=cb5f959dfb3009bcc2a6e4ebf162174e
index 7c411ad0a91e196ea5b01e4586a60b538f0c924d..7ba578211ea1bf89a578f8fbf951dd74fb5aed0a 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=jffs2 usb pci
 SUBTARGETS=au1500 au1550
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini yamonenv
index 2df7a8359432668d5ec48d932ad5bfeefc31fb64..7dbab3bd9bf2e5a8e1a62b5e94bb8b76e4b6f4a5 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb pcmcia
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 DEFAULT_PACKAGES += wpad-mini kmod-switch kmod-diag nvram
index e767c784ebeee53822e7bf31f265eaad1583033a..7d94ccd54ad75ccc7e69795ef30cd8827c2be577 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=targz pci ext4
 CFLAGS:=-O2 -pipe -mtune=r5000 -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 4e0f01373dc137b5dedb55535a3bc6a837e90199..4dfbf6b314492626c243165155ce1c7e023710e6 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs jffs2 ext4 targz usb
 CFLAGS:=-Os -pipe -march=armv4t -fno-caller-saves
 MAINTAINER:=Florian Fainelli <florian@openwrt.org>
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 4a7d351b644883921bf93036aec29d2def6ba59d..d4fa69d2390572d6bbb22804db3149a30d386ff8 100644 (file)
@@ -10,7 +10,7 @@
  static inline int io_type_enabled(struct pci_dev *pdev, unsigned int mask)
  {
        u16 cmd;
-@@ -894,3 +896,5 @@ static void __devinit quirk_usb_early_ha
+@@ -898,3 +900,5 @@ static void __devinit quirk_usb_early_ha
        pci_disable_device(pdev);
  }
  DECLARE_PCI_FIXUP_FINAL(PCI_ANY_ID, PCI_ANY_ID, quirk_usb_early_handoff);
index 389bc50ae7e95399a2469d6923e22f8e915fdb8c..a1b40600b083932ed41deb637d5f615f7b717f8a 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Lantiq GPON/XWAY
 FEATURES:=squashfs jffs2
 DEFAULT_SUBTARGET:=danube
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 CFLAGS=-Os -pipe -mips32r2 -mtune=mips32r2 -fno-caller-saves
 
index 5a6993d14f2104762c02c3c4749341d7a5fd20e7..b3bfd761b2fa8b584ef8bdec12044c14940d8992 100644 (file)
@@ -11,7 +11,7 @@ BOARD:=omap4
 BOARDNAME:=TI OMAP4
 FEATURES:=usb targz audio display
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 CFLAGS:=-Os -pipe -march=armv7-a -mfpu=vfpv3-d16 -mfloat-abi=softfp
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
index fc50bcd7d96fb99abd1b7d5181e81fa1b362c2ed..e5758343457b18e276f88cd400911645c37f86b5 100644 (file)
@@ -13,7 +13,7 @@ FEATURES:=squashfs
 CFLAGS:=-Os -pipe -fno-caller-saves -mcpu=440
 MAINTAINER:=Imre Kaloz <kaloz@openwrt.org>
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 include $(INCLUDE_DIR)/target.mk
 
index 475bd67e1855f8c6263ffd53e7a95d1e2585521c..52e00cf010f3e6eab8403870f01e87d20d4904db 100644 (file)
@@ -1,4 +1,4 @@
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 BOARDNAME:=PCEngines alix2
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
 DEFAULT_PACKAGES += \
index 5862a9901b623877591f3ab4bf79a45c04aca1f5..ddcbab3d325da44da89c3d157652d180192fd49f 100644 (file)
@@ -1,4 +1,4 @@
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 BOARDNAME:=Soekris net5501
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
 DEFAULT_PACKAGES += kmod-crypto-hw-geode kmod-crypto-ocf \
index 8763937f5444c1aa43336f152d7899d1693d63fa..db0731bf83fbec89cc352b01eaed757d3b60bf97 100644 (file)
@@ -12,7 +12,7 @@ BOARDNAME:=Ingenic XBurst
 FEATURES:=jffs2 targz ubifs audio
 SUBTARGETS:=qi_lb60 n516 n526 id800wt
 
-LINUX_VERSION:=3.2.15
+LINUX_VERSION:=3.2.16
 
 DEVICE_TYPE=other