update nmap to 4.01 (thanks to Richard Nadeau)
authorNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 15:21:14 +0000 (15:21 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 1 Apr 2006 15:21:14 +0000 (15:21 +0000)
SVN-Revision: 3566

openwrt/package/nmap/Config.in
openwrt/package/nmap/Makefile
openwrt/package/nmap/ipkg/nmap.control
openwrt/package/nmap/patches/cross-compile.patch
openwrt/package/nmap/patches/no_strip.patch

index d8ab98c6404ee59c4853137f35335251c4a7d560..ed85f9ca08ca032fcb590dd1adafb63cc87eeda5 100644 (file)
@@ -2,6 +2,7 @@ config BR2_PACKAGE_NMAP
        prompt "nmap.............................. Network exploration and/or security auditing utility"
        tristate
        default m if CONFIG_DEVEL
+       select BR2_PACKAGE_LIBDNET
        select BR2_PACKAGE_LIBPCAP
        select BR2_PACKAGE_LIBPCRE
        select BR2_PACKAGE_UCLIBCXX
index 23997b88fe95c1be0a522801b63ffe74eb3d7b3c..b60558f6fb0519beaae36f5e74c0ad191256403d 100644 (file)
@@ -3,9 +3,9 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=nmap
-PKG_VERSION:=3.81
-PKG_RELEASE:=2
-PKG_MD5SUM:=0713306dda85aee2c95ef31b4b7d2838
+PKG_VERSION:=4.01
+PKG_RELEASE:=1
+PKG_MD5SUM:=09c259837b24f6c7385c2c1c49760a7c
 
 PKG_SOURCE_URL:=http://download.insecure.org/nmap/dist
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
@@ -50,6 +50,7 @@ $(PKG_BUILD_DIR)/.configured:
                  $(DISABLE_NLS) \
                  --without-openssl \
                  --without-nmapfe \
+                 --with-libdnet="$(STAGING_DIR)/usr" \
                  --with-libpcap="$(STAGING_DIR)/usr" \
                  --with-libpcre="$(STAGING_DIR)/usr" \
        );
index 56253fda0b4a3630b6623c128e9a34e766842eb5..e5bedd47db81c0d9466ad90353c6f19ed1056da2 100644 (file)
@@ -1,5 +1,5 @@
 Package: nmap
 Priority: optional
 Section: net
-Depends: libgcc, libpcap, libpcre, uclibc++
+Depends: libgcc, libdnet, libpcap, libpcre, uclibc++
 Description: Nmap is a free open source utility for network exploration or security auditing.
index 4319a6b0e77b81f70eee1eb8ea5560cda9f7699f..5c3785c4b36cf4018b99b5a9c735575ee6df180e 100644 (file)
@@ -1,11 +1,11 @@
-diff -urN nmap-3.81.old/configure nmap-3.81.dev/configure
---- nmap-3.81.old/configure    2004-10-17 05:49:33.000000000 +0200
-+++ nmap-3.81.dev/configure    2005-04-26 14:47:42.000000000 +0200
-@@ -1339,12 +1339,6 @@
+diff -urN nmap-4.01.old/configure nmap-4.01.dev/configure
+--- nmap-4.01.old/configure    2006-02-01 19:18:42.000000000 -0700
++++ nmap-4.01.dev/configure    2006-03-29 23:14:28.000000000 -0700
+@@ -1341,12 +1341,6 @@
     fi
  fi
  
--libpcapdir=libpcap-possiblymodified
+-libpcapdir=libpcap
 -
 -
 -pcredir=libpcre
@@ -14,25 +14,28 @@ diff -urN nmap-3.81.old/configure nmap-3.81.dev/configure
            ac_config_headers="$ac_config_headers config.h"
  
  
-diff -urN nmap-3.81.old/Makefile.in nmap-3.81.dev/Makefile.in
---- nmap-3.81.old/Makefile.in  2005-02-07 07:14:03.000000000 +0100
-+++ nmap-3.81.dev/Makefile.in  2005-04-26 14:52:39.000000000 +0200
+diff -urN nmap-4.01.old/Makefile.in nmap-4.01.dev/Makefile.in
+--- nmap-4.01.old/Makefile.in  2006-02-09 19:22:27.000000000 -0700
++++ nmap-4.01.dev/Makefile.in  2006-03-29 23:14:12.000000000 -0700
 @@ -29,7 +29,7 @@
  # CFLAGS = $(DEFS) $(INCLS)
  STATIC =
  LDFLAGS = @LDFLAGS@ $(STATIC)
--LIBS =  @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ @LIBPCRE_LIBS@ @LIBPCAP_LIBS@ @OPENSSL_LIBS@ @LIBS@
-+LIBS =  @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ -lpcre -lpcap @OPENSSL_LIBS@ @LIBS@
+-LIBS =  @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ @LIBPCRE_LIBS@ @LIBPCAP_LIBS@ @OPENSSL_LIBS@ @LIBDNET_LIBS@ @LIBS@
++LIBS =  @LIBNBASE_LIBS@ @LIBNSOCK_LIBS@ -lpcre -lpcap @OPENSSL_LIBS@ -ldnet @LIBS@
  # LIBS =  -lefence @LIBS@
  # LIBS =  -lrmalloc @LIBS@
  SHTOOL = ./shtool
-@@ -69,12 +69,6 @@
+@@ -68,15 +68,6 @@
  # all of the prerequisites (e.g. recursive makes and such)
  FORCE:
  
 -$(LIBPCREDIR)/libpcre.a: $(LIBPCREDIR)/Makefile FORCE
 -      @echo Compiling libpcre; cd $(LIBPCREDIR) && $(MAKE)
 -
+-$(LIBDNETDIR)/src/.libs/libdnet.a: $(LIBDNETDIR)/Makefile FORCE
+-      @echo Compiling libdnet; cd $(LIBDNETDIR) && $(MAKE)
+-
 -$(LIBPCAPDIR)/libpcap.a: $(LIBPCAPDIR)/Makefile FORCE
 -      @echo Compiling libpcap; cd $(LIBPCAPDIR) && $(MAKE)
 -
index fa5825173a4723bd69bf1ae5c14c87a7feac49ae..ffe953e285cb69afb8745dab596f6b0d9010baa8 100644 (file)
@@ -1,11 +1,11 @@
-diff -ruN nmap-3.81-old/Makefile.in nmap-3.81-new/Makefile.in
---- nmap-3.81-old/Makefile.in  2005-10-02 16:32:52.000000000 +0200
-+++ nmap-3.81-new/Makefile.in  2005-10-02 16:34:46.000000000 +0200
-@@ -262,7 +262,7 @@
+diff -urN nmap-4.01.old/Makefile.in nmap-4.01.dev/Makefile.in
+--- nmap-4.01.old/Makefile.in  2006-02-09 19:22:27.000000000 -0700
++++ nmap-4.01.dev/Makefile.in  2006-03-29 23:14:12.000000000 -0700
+@@ -144,7 +135,7 @@
  
  install-nmap: $(TARGET)
        $(SHTOOL) mkdir -f -p -m 755 $(DESTDIR)$(bindir) $(DESTDIR)$(mandir)/man1 $(DESTDIR)$(nmapdatadir)
--      $(INSTALL) -c -m 755 nmap -s $(DESTDIR)$(bindir)/nmap
+-      $(INSTALL) -c -m 755 -s nmap $(DESTDIR)$(bindir)/nmap
 +      $(INSTALL) -c -m 755 nmap $(DESTDIR)$(bindir)/nmap
        $(INSTALL) -c -m 644 docs/$(TARGET).1 $(DESTDIR)$(mandir)/man1/$(TARGET).1
        $(INSTALL) -c -m 644 docs/nmap.xsl $(DESTDIR)$(nmapdatadir)/