Enable mod-ulogd-pcap build
authorFlorian Fainelli <florian@openwrt.org>
Wed, 19 Apr 2006 10:07:20 +0000 (10:07 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 19 Apr 2006 10:07:20 +0000 (10:07 +0000)
SVN-Revision: 3671

openwrt/package/depend.mk
openwrt/package/ulogd/Config.in
openwrt/package/ulogd/Makefile
openwrt/package/ulogd/ipkg/ulogd-mod-pcap.control [new file with mode: 0644]
openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch [new file with mode: 0644]

index 043e637d6070e6ecc0a3dfddcaf2575c4e8c29ab..f2d20415e35dce617b56c336df44a2b237b46060 100644 (file)
@@ -273,6 +273,9 @@ ulogd-compile: iptables-compile
 ifneq ($(BR2_PACKAGE_ULOGD_MOD_MYSQL),)
 ulogd-compile: mysql-compile
 endif
+ifneq ($(BR2_PACKAGE_ULOGD_MOD_PCAP),)
+ulogd-compile: pcap-compile
+endif
 ifneq ($(BR2_PACKAGE_ULOGD_MOD_PGSQL),)
 ulogd-compile: postgresql-compile
 endif
index 81142d92f88d99538ec9bc905ccac6c3cbe57769..51b0f56db3563087da890bd14754bbcb6b9c5b3a 100644 (file)
@@ -17,6 +17,13 @@ config BR2_PACKAGE_ULOGD_MOD_MYSQL
        depends BR2_PACKAGE_ULOGD
        select BR2_PACKAGE_LIBMYSQLCLIENT
 
+config BR2_PACKAGE_ULOGD_MOD_PCAP
+        prompt  "ulogd-mod-pcap................... Output plugin for logging into pcap format"
+       tristate
+       default m if CONFIG_DEVEL
+       depends BR2_PACKAGE_ULOGD
+       select BR2_PACKAGE_LIBPCAP
+
 config BR2_PACKAGE_ULOGD_MOD_PGSQL
        prompt   "ulogd-mod-pgsql................. Output plugin for logging into a PostgreSQL database"
        tristate
index 893fd5b8f99576715a7a98598b78c4a8e6938224..a399b07613911ec11df0a10f23b44658b65bbaf3 100644 (file)
@@ -21,6 +21,12 @@ ifneq ($(BR2_PACKAGE_ULOGD_MOD_MYSQL),)
 ULOGD_MYSQL_OPTION:=--with-mysql=$(STAGING_DIR)/usr
 endif
 
+ifneq ($(BR2_PACKAGE_ULOGD_MOD_PCAP),)
+ULOGD_PCAP_HEADER:=yes
+else
+ULOGD_PCAP_HEADER:=no
+endif
+
 ifneq ($(BR2_PACKAGE_ULOGD_MOD_PGSQL),)
 ULOGD_PGSQL_OPTION:=--with-pgsql=$(STAGING_DIR)/usr
 endif
@@ -43,9 +49,11 @@ $(eval $(call PKG_template,ULOGD,ulogd,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_MYSQL,ulogd-mod-mysql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_PGSQL,ulogd-mod-pgsql,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,ULOGD_MOD_EXTRA,ulogd-mod-extra,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
+$(eval $(call PKG_template,ULOGD_MOD_EXTRA,ulogd-mod-pcap,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_MYSQL,MYSQL))
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_PGSQL,PGSQL))
+$(eval $(call IPKG_plugin_template,ULOGD_MOD_PCAP,PCAP))
 $(eval $(call IPKG_plugin_template,ULOGD_MOD_EXTRA,LOCAL LOGEMU OPRINT PWSNIFF SYSLOG))
 
 $(PKG_BUILD_DIR)/.configured:
@@ -54,7 +62,7 @@ $(PKG_BUILD_DIR)/.configured:
                CFLAGS="$(TARGET_CFLAGS)" \
                CPPFLAGS="-I$(STAGING_DIR)/usr/include -I$(STAGING_DIR)/include" \
                LDFLAGS="-L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib" \
-               ac_cv_header_pcap_h=no \
+               ac_cv_header_pcap_h=$(ULOGD_PCAP_HEADER) \
                ./configure \
                        --target=$(GNU_TARGET_NAME) \
                        --host=$(GNU_TARGET_NAME) \
@@ -87,6 +95,7 @@ $(PKG_BUILD_DIR)/.built:
        mkdir -p $(PKG_INSTALL_DIR)
        $(MAKE) -C $(PKG_BUILD_DIR) \
                DESTDIR="$(PKG_INSTALL_DIR)" \
+               STAGING_DIR=$(STAGING_DIR) \
                all install
        touch $@
 
diff --git a/openwrt/package/ulogd/ipkg/ulogd-mod-pcap.control b/openwrt/package/ulogd/ipkg/ulogd-mod-pcap.control
new file mode 100644 (file)
index 0000000..521ad94
--- /dev/null
@@ -0,0 +1,5 @@
+Package: ulogd-mod-pcap
+Priority: optional
+Section: net
+Description: Netfilter userspace logging daemon (PCAP plugin)
+Depends: libpcap, ulogd
diff --git a/openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch b/openwrt/package/ulogd/patches/ulogd-1.23-pcap_ldflags.patch
new file mode 100644 (file)
index 0000000..d451823
--- /dev/null
@@ -0,0 +1,12 @@
+diff -urN ulogd-1.23/pcap/Makefile.in ulogd-1.23.new/pcap/Makefile.in
+--- ulogd-1.23/pcap/Makefile.in        2004-03-23 23:36:04.000000000 +0100
++++ ulogd-1.23.new/pcap/Makefile.in    2006-04-19 11:30:45.000000000 +0200
+@@ -14,7 +14,7 @@
+ distrib:
+ $(SHARED_LIBS): %.so: %_sh.o
+-      $(LD) -shared -o $@ $< -lc -lpcap
++      $(LD) -shared -o $@ $< -lc -lpcap -L$(STAGING_DIR)/usr/lib -L$(STAGING_DIR)/lib
+ %_sh.o: %.c
+       $(CC) $(SH_CFLAGS) -o $@ -c $<