package I2C_MUX_GPIO
authorJohn Crispin <john@openwrt.org>
Sat, 1 Oct 2011 22:36:47 +0000 (22:36 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 1 Oct 2011 22:36:47 +0000 (22:36 +0000)
this module was missing from [28334]

buildbots timed out as the symbol was not defined

SVN-Revision: 28352

package/kernel/modules/i2c.mk

index f6b1cdff6fb4e0e5978b832450adfa7051a8cb18..8b1e5a3e49efef8a8b486fd66bd18379857fcea5 100644 (file)
@@ -245,6 +245,21 @@ endef
 
 $(eval $(call KernelPackage,i2c-mux))
 
+I2C_MUX_GPIO_MODULES:= \
+  CONFIG_I2C_MUX_GPIO:drivers/i2c/muxes/gpio-i2cmux
+
+define KernelPackage/i2c-mux-gpio
+  $(call i2c_defaults,$(I2C_MUX_GPIO_MODULES),51)
+  TITLE:=GPIO-based I2C mux/switches
+  DEPENDS:=kmod-i2c-mux
+endef
+
+define KernelPackage/i2c-mux-gpio/description
+ Kernel modules for GENERIC_GPIO I2C bus mux/switching devices.
+endef
+
+$(eval $(call KernelPackage,i2c-mux-gpio))
+
 I2C_MUX_PCA954x_MODULES:= \
   CONFIG_I2C_MUX_PCA954x:drivers/i2c/muxes/pca954x