ramips: add support for Wavlink WL-WN533A8
authorDavide Fioravanti <pantanastyle@gmail.com>
Mon, 18 Apr 2022 15:35:33 +0000 (17:35 +0200)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 30 Apr 2022 21:56:47 +0000 (23:56 +0200)
The Wavlink WL-WN533A8 is an AC3000 router with 5 gigabit ethernet ports
and one USB 3.0 port.
It's also known as Wavlink QUANTUM T8.

Hardware
--------
SoC:   Mediatek MT7621A
RAM:   128MB (Nanya NT5CB64M16GP-EK)
FLASH: 16MB NOR (GigaDevice GD25Q127CSIG3)
ETH:
  - 5x 10/100/1000 Mbps Ethernet (4x LAN + 1x WAN)
WIFI:
  - 1x MT7615DN (2x 2x2:2) 2.4GHz and 5GHz DBDC
  - 1x MT7615NE (4x4:4) 5GHz
  - 8 external antennas
BTN:
  - 1x Reset button
  - 1x WPS button
  - 1x Turbo button
  - 1x Touchlink button
  - 1x ON/OFF switch
LEDS:
  - 1x Red led (system status)
  - 1x Blue led (system status)
  - 7x Blue leds (wifi led + 5 ethernet ports + power)
USB:
  - 1x USB 3.0 port
UART:
  - 57600-8-N-1
    J4

Everything works correctly.

Installation
------------
Flash the initramfs image in the OEM firmware interface
(http://192.168.10.1/update.shtml).
When Openwrt boots, flash the sysupgrade image otherwise you won't be
able to keep configuration between reboots.
(Procedure tested on fw M33A8.V5030.190716 and M33A8.V5030.201204)

Restore OEM Firmware
--------------------
Flash the firmware update available online directly from LUCI.
You can download it from:
https://www.wavlink.com/en_us/firmware/details/f2d247ecba.html
Warning: Remember to not keep settings!
Warning2: Remember to force the flash.

Notes
-----
1) Router mac addresses:
   LAN XX:XX:XX:XX:XX:63 (factory @ 0xe006)
   WAN XX:XX:XX:XX:XX:64 (factory @ 0xe000)
   WIFI 2G/5G XX:XX:XX:XX:XX:65 (factory @ 0x04)
   WIFI 5G XX:XX:XX:XX:XX:66 (factory @ 0x8004)

   LABEL XX:XX:XX:XX:XX:65

   In OEM firmware the DBDC wifi interfaces have these mac addresses:
     2G) 82:XX:XX:XX:XX:65
     5G) 80:XX:XX:XX:XX:65

   While in OpenWrt the addresses are:
     2G) 80:XX:XX:XX:XX:65
     5G) 02:XX:XX:XX:XX:65

2) radio0 will show as 2G/5G interface but only 2G is really usable.

3) There is just one wifi led for all wifi interfaces.
   It currently shows only the radio0 GHz wifi activity.

4) My unit was shipped with M33A8.V5030.190716 firmware which contains
   the http://192.168.10.1/webcmd.shtml page. Entering "telnetd" in
   the input box it will start the telnet daemon. Now you can access
   the telnet console on port 2323 with these credentials:
     username: admin2860
     password: admin

5) The M33A8.V5030.201204 firmware version, doesn't contain anymore the
   webcmd.shtml page. If your router is shipped with a previous firmware
   version and you want to back it up, you can follow the back up
   procedure of the WS-WN583A6.

Signed-off-by: Davide Fioravanti <pantanastyle@gmail.com>
target/linux/ramips/dts/mt7621_wavlink_wl-wn533a8.dts [new file with mode: 0644]
target/linux/ramips/image/mt7621.mk
target/linux/ramips/mt7621/base-files/etc/board.d/02_network

diff --git a/target/linux/ramips/dts/mt7621_wavlink_wl-wn533a8.dts b/target/linux/ramips/dts/mt7621_wavlink_wl-wn533a8.dts
new file mode 100644 (file)
index 0000000..9a601d6
--- /dev/null
@@ -0,0 +1,32 @@
+// SPDX-License-Identifier: GPL-2.0-or-later OR MIT
+
+#include "mt7621_wavlink_wl-wn53xax.dtsi"
+
+/ {
+       compatible = "wavlink,wl-wn533a8", "mediatek,mt7621-soc";
+       model = "Wavlink WL-WN533A8";
+};
+
+&wifi0{
+       ieee80211-freq-limit = <2400000 5490000>;
+};
+
+&wifi1{
+       ieee80211-freq-limit = <5490000 6000000>;
+};
+
+&port0{
+       label = "lan4";
+};
+
+&port1{
+       label = "lan3";
+};
+
+&port2{
+       label = "lan2";
+};
+
+&port3{
+       label = "lan1";
+};
index 3793bf69d6294069a8efb31f462a53af535f944d..5844682a4032a6e12c9b1e27bd17699b8255214b 100644 (file)
@@ -1762,6 +1762,16 @@ define Device/wavlink_wl-wn531a6
 endef
 TARGET_DEVICES += wavlink_wl-wn531a6
 
+define Device/wavlink_wl-wn533a8
+  $(Device/dsa-migration)
+  DEVICE_VENDOR := Wavlink
+  DEVICE_MODEL := WL-WN533A8
+  KERNEL_INITRAMFS_SUFFIX := -WN533A8$$(KERNEL_SUFFIX)
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7615-firmware kmod-usb3
+  IMAGE_SIZE := 15040k
+endef
+TARGET_DEVICES += wavlink_wl-wn533a8
+
 define Device/wevo_11acnas
   $(Device/dsa-migration)
   $(Device/uimage-lzma-loader)
index 75842f4cbc07ff83a76b186f2345e12f8bac9e23..688c39940d6e5f8e46984d1f7ea3b9c8b75dca34 100644 (file)
@@ -166,6 +166,7 @@ ramips_setup_macs()
                ;;
        jcg,y2|\
        wavlink,wl-wn531a6|\
+       wavlink,wl-wn533a8|\
        winstars,ws-wn583a6|\
        zbtlink,zbt-we1326|\
        zbtlink,zbt-wg3526-16m|\