fix rootfs preparation with rootfs containing files with whitespaces in the filename...
authorFelix Fietkau <nbd@openwrt.org>
Fri, 22 Jan 2010 23:10:57 +0000 (23:10 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Fri, 22 Jan 2010 23:10:57 +0000 (23:10 +0000)
SVN-Revision: 19282

include/image.mk

index ac8093704900948adb4764b65b7c0a64c47f0c01..990ce8e4003e017a4a19bb3c23a510ce7f20657e 100644 (file)
@@ -126,9 +126,9 @@ endif
 
 
 define Image/mkfs/prepare/default
-       - find $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' | $(XARGS) chmod 0644
-       - find $(TARGET_DIR) -type f -perm +0100 | $(XARGS) chmod 0755
-       - find $(TARGET_DIR) -type d | $(XARGS) chmod 0755
+       - $(FIND) $(TARGET_DIR) -type f -not -perm +0100 -not -name 'ssh_host*' -print0 | $(XARGS) -0 chmod 0644
+       - $(FIND) $(TARGET_DIR) -type f -perm +0100 -print0 | $(XARGS) -0 chmod 0755
+       - $(FIND) $(TARGET_DIR) -type d -print0 | $(XARGS) -0 chmod 0755
        $(INSTALL_DIR) $(TARGET_DIR)/tmp
        chmod 0777 $(TARGET_DIR)/tmp
 endef